Bug 65772 - font:inherit on select elements causing reload
Summary: font:inherit on select elements causing reload
Status: RESOLVED DUPLICATE of bug 65350
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://www.bankofcanada.ca
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-05 09:08 PDT by Lindsay Newton
Modified: 2011-08-05 12:28 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lindsay Newton 2011-08-05 09:08:01 PDT
Over the past week or so we've been receiving user feedback from users running Safari 5.1 that select elements were not working correctly on our site. After testing on various browsers on both Windows XP and Mac OS X 10.6.8 we've determined it's only an issue when running Safari 5.1 on Mac.

We've narrowed the issue down to a CSS bug (JavaScript disabled). It seems that removing 'font:inherit' fixes the problem.

Steps to Reproduce:
Visit the URL and attempt to use any drop-down select menu on the site. On the header of the main page there is a select element used beside the search form. The behaviour can be reproduced by clicking on that.

Observed Behaviour:
The page reloads.

Expected Behaviour:
Clicking on the select element should display the list of options associated to that select.

Additional Builds and Platforms:
Tested on OS X 10.6.7 with Safari 5.05 (no issue)
Tested on OS X 10.6.8 with Firefox 3.6.6 (no issue)
Tested on Windows XP with Safari 5.1 (no issue)
Tested on Windows XP with IE7, Firefox 5.0, Chrome 13 (no issue)

Notes: 
-We have not tested this in OS X 10.7
-We are using webfonts

Date first reported: July 25, 2011
Browser: Safari 5.1 (6534.50)
WebKit: 534.50
OS: Mac OS X 10.6.8
Comment 1 Lindsay Newton 2011-08-05 09:15:54 PDT
Also tested in Chrome on Mac OS X 10.6.8 version 13.0.782.107 (webkit 535.1) and Canary version 15.0.845.0 (webkit 535.1). No issues there either.
Comment 2 Alexey Proskuryakov 2011-08-05 12:04:44 PDT
Thank you for the bug report! This sounds like a known issue that has been recently fixed. Could you please verify that the problem does not occur when using a WebKit nightly from <http://nightly.webkit.org>?

*** This bug has been marked as a duplicate of bug 65350 ***
Comment 3 Lindsay Newton 2011-08-05 12:28:24 PDT
Unfortunately we can't seem to download the build to test. It seems to be blocked internally. We'll follow up when we are able to test.