Bug 65771 - REGRESSION(r92433): media/video-src-change.html fails
Summary: REGRESSION(r92433): media/video-src-change.html fails
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Ryosuke Niwa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-05 09:07 PDT by Ryosuke Niwa
Modified: 2011-08-05 12:49 PDT (History)
6 users (show)

See Also:


Attachments
fixes the test (1.21 KB, patch)
2011-08-05 09:46 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2011-08-05 09:07:00 PDT
media/video-src-change.html started to fail after http://trac.webkit.org/changeset/92433 because the test assumes the second argument for removeEventListener to be optional.
Comment 1 Ryosuke Niwa 2011-08-05 09:10:45 PDT
All regressions are P1.
Comment 2 Ryosuke Niwa 2011-08-05 09:15:06 PDT
Looking at EventTarget code:
http://trac.webkit.org/browser/trunk/Source/WebCore/dom/EventTarget.cpp#L246

It seems like the test code is wrong.  We should be giving the listener as the second argument:
31	                if (++loadedCount >= 2) {
32	                    mediaElement.removeEventListener('loadedmetadata');
33	                    endTest();
34	                    return;
35	                }
Comment 3 Ryosuke Niwa 2011-08-05 09:46:58 PDT
Created attachment 103079 [details]
fixes the test
Comment 4 Ryosuke Niwa 2011-08-05 10:13:04 PDT
Comment on attachment 103079 [details]
fixes the test

Clearing flags on attachment: 103079

Committed r92484: <http://trac.webkit.org/changeset/92484>
Comment 5 Ryosuke Niwa 2011-08-05 10:13:07 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Adam Barth 2011-08-05 12:49:56 PDT
This bug is blowing my mind.  I thought removeEventListener was special-cased by the code generator.  The IDL files shouldn't affect the generated code.