Bug 65698 - REGRESSION: webkitRequestAnimationFrame's element argument needs to be marked optional
Summary: REGRESSION: webkitRequestAnimationFrame's element argument needs to be marked...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Darin Fisher (:fishd, Google)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 09:51 PDT by Darin Fisher (:fishd, Google)
Modified: 2011-08-04 12:41 PDT (History)
5 users (show)

See Also:


Attachments
v1 patch (1.24 KB, patch)
2011-08-04 10:28 PDT, Darin Fisher (:fishd, Google)
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff
v2 patch (1.26 KB, patch)
2011-08-04 10:51 PDT, Darin Fisher (:fishd, Google)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Fisher (:fishd, Google) 2011-08-04 09:51:28 PDT
REGRESSION: webkitRequestAnimationFrame's element argument needs to be marked optional

regressed from http://trac.webkit.org/changeset/92313
Comment 1 Darin Fisher (:fishd, Google) 2011-08-04 10:28:56 PDT
Created attachment 102942 [details]
v1 patch
Comment 2 WebKit Review Bot 2011-08-04 10:38:09 PDT
Comment on attachment 102942 [details]
v1 patch

Attachment 102942 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/9300730
Comment 3 Darin Fisher (:fishd, Google) 2011-08-04 10:51:11 PDT
Created attachment 102945 [details]
v2 patch

Whoops, this time with Optional=CallWithDefaultValue!
Comment 4 James Robinson 2011-08-04 11:02:47 PDT
Comment on attachment 102945 [details]
v2 patch

R=me
Comment 5 WebKit Review Bot 2011-08-04 11:19:57 PDT
Comment on attachment 102945 [details]
v2 patch

Clearing flags on attachment: 102945

Committed r92392: <http://trac.webkit.org/changeset/92392>
Comment 6 WebKit Review Bot 2011-08-04 11:20:02 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Adam Barth 2011-08-04 11:51:20 PDT
Comment on attachment 102945 [details]
v2 patch

No test?  Thanks for fixing this issue.  Sorry for the mess.
Comment 8 Darin Fisher (:fishd, Google) 2011-08-04 12:40:02 PDT
See fast/animation/request-animation-frame-*, which are all skipped on non-Chromium ports.  It looks like I should indeed have added a test that does not pass the element parameter :(  Will do that as a follow-up patch in a separate bug.
Comment 9 Darin Fisher (:fishd, Google) 2011-08-04 12:41:33 PDT
See bug 65710 for adding a test.