Bug 65682 - Web Inspector: Rename sourceId -> scriptId in the protocol and the source code.
Summary: Web Inspector: Rename sourceId -> scriptId in the protocol and the source code.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Feldman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 05:06 PDT by Pavel Feldman
Modified: 2011-08-04 06:07 PDT (History)
11 users (show)

See Also:


Attachments
Patch (56.26 KB, patch)
2011-08-04 05:16 PDT, Pavel Feldman
no flags Details | Formatted Diff | Diff
Patch (56.29 KB, patch)
2011-08-04 05:29 PDT, Pavel Feldman
no flags Details | Formatted Diff | Diff
Patch (47.29 KB, patch)
2011-08-04 06:01 PDT, Pavel Feldman
yurys: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Feldman 2011-08-04 05:06:07 PDT
Patch to follow.
Comment 1 Pavel Feldman 2011-08-04 05:16:09 PDT
Created attachment 102897 [details]
Patch
Comment 2 WebKit Review Bot 2011-08-04 05:19:58 PDT
Attachment 102897 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/http..." exit_code: 1

Source/WebCore/inspector/InspectorDebuggerAgent.cpp:184:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:214:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:318:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:318:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:85:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:90:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:90:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 7 in 22 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Yury Semikhatsky 2011-08-04 05:25:55 PDT
Comment on attachment 102897 [details]
Patch

Please split this change into two: sourceId->scriptId rename and the breakpoint url regex related change.
Comment 4 Pavel Feldman 2011-08-04 05:29:25 PDT
Created attachment 102899 [details]
Patch
Comment 5 WebKit Review Bot 2011-08-04 05:30:42 PDT
Attachment 102899 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/http..." exit_code: 1

Source/WebCore/inspector/InspectorDebuggerAgent.cpp:184:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:214:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:318:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:318:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:85:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:90:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:90:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 7 in 22 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Pavel Feldman 2011-08-04 06:01:06 PDT
Created attachment 102901 [details]
Patch
Comment 7 WebKit Review Bot 2011-08-04 06:03:20 PDT
Attachment 102901 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/http..." exit_code: 1

Source/WebCore/inspector/InspectorDebuggerAgent.cpp:208:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:312:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.cpp:312:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:90:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:90:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 5 in 20 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 8 Pavel Feldman 2011-08-04 06:07:45 PDT
Committed r92369: <http://trac.webkit.org/changeset/92369>