Bug 65591 - Copying and pasting text in h1 - h6 will result in nested h1 - h6
Summary: Copying and pasting text in h1 - h6 will result in nested h1 - h6
Status: RESOLVED DUPLICATE of bug 26483
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-02 19:13 PDT by Ryosuke Niwa
Modified: 2011-08-03 11:55 PDT (History)
4 users (show)

See Also:


Attachments
demo (181 bytes, text/html)
2011-08-02 19:13 PDT, Ryosuke Niwa
no flags Details
work in progress (10.27 KB, patch)
2011-08-02 19:22 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2011-08-02 19:13:10 PDT
Created attachment 102732 [details]
demo

Ultimately, we'd have to fix the bug 34564 to fix the root cause of all these crazy markup but we can fix this particular case.

To reproduce this bug, select all, copy & paste in the attached demo
Comment 1 Ryosuke Niwa 2011-08-02 19:22:23 PDT
Created attachment 102733 [details]
work in progress

The idea here is to extend r81887 and r83322 to remove most of block nodes as well.
Comment 2 Alexey Proskuryakov 2011-08-03 10:32:28 PDT
Duplicate of bug 26483?
Comment 3 Ryosuke Niwa 2011-08-03 10:41:50 PDT
(In reply to comment #2)
> Duplicate of bug 26483?

Yes! I was looking for that bug yesterday but couldn't find it.
Comment 4 Ryosuke Niwa 2011-08-03 11:55:39 PDT

*** This bug has been marked as a duplicate of bug 26483 ***