WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
65518
Web Inspector: there should be a way to tell what properties are non-enumerable when expanding objects.
https://bugs.webkit.org/show_bug.cgi?id=65518
Summary
Web Inspector: there should be a way to tell what properties are non-enumerab...
Pavel Feldman
Reported
2011-08-01 23:21:00 PDT
<user report>
Attachments
Patch
(24.04 KB, patch)
2011-08-09 01:41 PDT
,
Pavel Feldman
no flags
Details
Formatted Diff
Diff
[IMAGE] Looks with patch applied.
(93.84 KB, image/png)
2011-08-09 01:41 PDT
,
Pavel Feldman
no flags
Details
Show Obsolete
(1)
View All
Add attachment
proposed patch, testcase, etc.
Pavel Feldman
Comment 1
2011-08-09 01:41:15 PDT
Created
attachment 103336
[details]
Patch
Pavel Feldman
Comment 2
2011-08-09 01:41:39 PDT
Created
attachment 103337
[details]
[IMAGE] Looks with patch applied.
WebKit Review Bot
Comment 3
2011-08-09 01:44:31 PDT
Attachment 103336
[details]
did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/insp..." exit_code: 1 Source/WebCore/inspector/InjectedScript.cpp:88: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] Source/WebCore/inspector/InspectorRuntimeAgent.h:73: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] Source/WebCore/inspector/InspectorRuntimeAgent.cpp:112: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] Source/WebCore/inspector/InjectedScript.h:73: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] Total errors found: 4 in 14 files If any of these errors are false positives, please file a bug against check-webkit-style.
Yury Semikhatsky
Comment 4
2011-08-09 01:57:19 PDT
Comment on
attachment 103336
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=103336&action=review
> Source/WebCore/inspector/Inspector.json:245 > + { "name": "get", "$ref": "RemoteObject", "description": "A function which serves as a getter for the property, or <code>undefined</code> if there is no getter (accessor descriptors only)." },
get -> getter
> Source/WebCore/inspector/Inspector.json:246 > + { "name": "set", "$ref": "RemoteObject", "description": "A function which serves as a setter for the property, or <code>undefined</code> if there is no setter (accessor descriptors only)." },
set -> setter
> Source/WebCore/inspector/Inspector.json:296 > + { "name": "ownProperties", "optional": true, "type": "boolean", "description": "If true, returns properties belonging only to the element itself, not to its prototype chain." }
ownProperties -> ownPropertiesOnly ?
> Source/WebCore/inspector/front-end/RemoteObject.js:230 > + this.writable = descriptor ? !!descriptor.writable : true;
Please remove !! before descriptor.writable
Pavel Feldman
Comment 5
2011-08-09 02:01:35 PDT
(In reply to
comment #4
)
> (From update of
attachment 103336
[details]
) > View in context:
https://bugs.webkit.org/attachment.cgi?id=103336&action=review
> > > Source/WebCore/inspector/Inspector.json:245 > > + { "name": "get", "$ref": "RemoteObject", "description": "A function which serves as a getter for the property, or <code>undefined</code> if there is no getter (accessor descriptors only)." }, > > get -> getter >
I agree here, but I think sticking with the ECMA spec is more important.
> > Source/WebCore/inspector/Inspector.json:246 > > + { "name": "set", "$ref": "RemoteObject", "description": "A function which serves as a setter for the property, or <code>undefined</code> if there is no setter (accessor descriptors only)." }, > > set -> setter
ditto
> > > Source/WebCore/inspector/Inspector.json:296 > > + { "name": "ownProperties", "optional": true, "type": "boolean", "description": "If true, returns properties belonging only to the element itself, not to its prototype chain." } > > ownProperties -> ownPropertiesOnly ? >
I think present way is more clear, see the documentation field.
> > Source/WebCore/inspector/front-end/RemoteObject.js:230 > > + this.writable = descriptor ? !!descriptor.writable : true; > > Please remove !! before descriptor.writable
Done.
Pavel Feldman
Comment 6
2011-08-09 02:05:31 PDT
Committed
r92670
: <
http://trac.webkit.org/changeset/92670
>
Csaba Osztrogonác
Comment 7
2011-08-09 03:22:10 PDT
It broke 3 inspector tests on all bot: -
http://build.webkit.org/results/Leopard%20Intel%20Debug%20%28Tests%29/r92670%20%2832897%29/results.html
-
http://build.webkit.org/results/Windows%207%20Release%20%28Tests%29/r92670%20%2815313%29/results.html
-
http://build.webkit.org/results/Qt%20Linux%20Release/r92670%20%2836302%29/results.html
Csaba Osztrogonác
Comment 8
2011-08-09 03:28:24 PDT
Reopen, because it was rolled out by
https://trac.webkit.org/changeset/92671
Pavel Feldman
Comment 9
2011-08-10 06:41:51 PDT
Committed
r92765
: <
http://trac.webkit.org/changeset/92765
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug