Bug 65388 - subsequent onload events have bad dimensions when a beforeload handler is installed.
: subsequent onload events have bad dimensions when a beforeload handler is ins...
Status: RESOLVED DUPLICATE of bug 45586
Product: WebKit
Classification: Unclassified
Component: WebCore Misc.
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Gavin Peters
Depends on:
  Show dependency treegraph
Reported: 2011-07-29 13:41 PDT by Gavin Peters
Modified: 2011-09-13 01:26 PDT (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Peters 2011-07-29 13:41:35 PDT
If, and apparently only if, you have a beforeload handler installed, subsequent loads of already loaded images gets bogus dimensions for the element in the onload handler.

Read source on the URL above for a good reproduction.

Believe it or not, commenting out the beforeload handler makes this go away.

This is a minimisation of what users were seeing in chrome bug 72484: http://code.google.com/p/chromium/issues/detail?id=72484
Comment 1 Alexey Proskuryakov 2011-08-01 15:59:19 PDT
See also: bug 45586.
Comment 2 Gavin Peters 2011-08-02 06:43:14 PDT
And I'd be shocked if https://bugs.webkit.org/show_bug.cgi?id=52581 wasn't closely related, too.
Comment 3 Michael Gundlach 2011-08-02 15:46:45 PDT
A fix will make a vocal subset of AdBlock users very happy :)
Comment 4 Andy Estes 2011-09-13 01:26:08 PDT
I think this is actually a dupe of bug 45586. Please correct me if I'm wrong.

*** This bug has been marked as a duplicate of bug 45586 ***