Bug 65374 - WebSocket: Rename SocketStreamHandleClient member functions
Summary: WebSocket: Rename SocketStreamHandleClient member functions
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Yuta Kitamura
URL:
Keywords:
Depends on:
Blocks: 65249
  Show dependency treegraph
 
Reported: 2011-07-29 06:52 PDT by Yuta Kitamura
Modified: 2011-08-01 00:27 PDT (History)
4 users (show)

See Also:


Attachments
Patch (21.35 KB, patch)
2011-07-29 06:57 PDT, Yuta Kitamura
no flags Details | Formatted Diff | Diff
Patch for landing (21.41 KB, patch)
2011-07-31 23:06 PDT, Yuta Kitamura
no flags Details | Formatted Diff | Diff
Patch for landing (21.40 KB, patch)
2011-07-31 23:12 PDT, Yuta Kitamura
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuta Kitamura 2011-07-29 06:52:32 PDT
To implement WebSocket binary messages (bug 65249), I happened to know the names of SocketStreamHandleClient methods conflict with FileReaderLoaderClient methods (which will be used to load a Blob content).

SocketStreamHandleClient:
    virtual void didReceiveData(SocketStreamHandle*, const char*, int);
    virtual void didFail(SocketStreamHandle*, const SocketStreamError&);

FileReaderLoaderClient:
    virtual void didReceiveData();
    virtual void didFail();

I think it's impossible to write a class deriving from these classes (a method from one class may hide one from the other, maybe?). Even if it's valid, it's extremely confusing to have both, so I'd like to rename SocketStreamHandleClient methods to avoid this clash.
Comment 1 Yuta Kitamura 2011-07-29 06:57:28 PDT
Created attachment 102357 [details]
Patch
Comment 2 Kent Tamura 2011-07-31 19:28:54 PDT
Comment on attachment 102357 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=102357&action=review

> Source/WebCore/ChangeLog:3
> +        WebSocket: Rename SocketStreamHandleClient methods

nit: In C++, they are called "member function", not "method".

> Source/WebCore/ChangeLog:8
> +        Rename SocketStreamHandleClient methods to avoid conflict of the names of FileReaderLoaderClient methods.

ditto.

> Source/WebCore/websockets/WebSocketChannel.h:68
> +        // SocketStreamHandleClient methods.

ditto.

> Source/WebKit/chromium/ChangeLog:3
> +        WebSocket: Rename SocketStreamHandleClient methods

ditto.
Comment 3 Yuta Kitamura 2011-07-31 23:06:06 PDT
Created attachment 102480 [details]
Patch for landing
Comment 4 Yuta Kitamura 2011-07-31 23:12:33 PDT
Created attachment 102482 [details]
Patch for landing
Comment 5 WebKit Review Bot 2011-08-01 00:27:00 PDT
Comment on attachment 102482 [details]
Patch for landing

Clearing flags on attachment: 102482

Committed r92102: <http://trac.webkit.org/changeset/92102>
Comment 6 WebKit Review Bot 2011-08-01 00:27:05 PDT
All reviewed patches have been landed.  Closing bug.