Bug 65155 - [chromium] fast/selectors/001.html is a flaky crasher
Summary: [chromium] fast/selectors/001.html is a flaky crasher
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ami Fischman
URL:
Keywords:
: 65129 65149 65152 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-25 17:27 PDT by Adrienne Walker
Modified: 2011-08-02 10:46 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.87 KB, patch)
2011-08-01 14:35 PDT, Ami Fischman
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adrienne Walker 2011-07-25 17:27:35 PDT
http://test-results.appspot.com/dashboards/flakiness_dashboard.html#showExpectations=true&tests=fast%2Fselectors%2F001.html

First crashing revision on Linux (but it's sporadic):
WebKit blamelist r91628:r91628
Chrome blamelist r93740:r93742

[21254:21254:438114005583:ERROR:process_util_posix.cc(134)] Received signal 11
	base::debug::StackTrace::StackTrace() [0x70dfae]
	base::(anonymous namespace)::StackDumpSignalHandler() [0x6ffb53]
	0x7fbdd1b31af0
	webkit_glue::DataSourceInitDone() [0x11fd484]
	base::internal::Invoker3<>::DoInvoke() [0x11fd990]
	webkit_glue::BufferedDataSource::DoneInitialization_Locked() [0x11f59b4]
	webkit_glue::BufferedDataSource::NonHttpInitialStartCallback() [0x11f7572]
	webkit_glue::BufferedResourceLoader::DoneStart() [0x11f886e]
	webkit_glue::BufferedResourceLoader::didReceiveResponse() [0x11f9e61]
	WebKit::AssociatedURLLoader::ClientAdapter::didReceiveResponse() [0x46c590]
	WebCore::DocumentThreadableLoader::didReceiveResponse() [0xd8da88]
	WebCore::SubresourceLoader::didReceiveResponse() [0xdcacf1]
	webkit_glue::WebURLLoaderImpl::Context::OnReceivedResponse() [0x11e68d7]
	(anonymous namespace)::TaskClosureAdapter::Run() [0x6eedae]
	MessageLoop::RunTask() [0x6f3577]
	MessageLoop::DeferOrRunPendingTask() [0x6f3b48]
	MessageLoop::DoWork() [0x6f3e80]
	base::MessagePumpGlib::RunWithDispatcher() [0x708e79]
	MessageLoop::RunInternal() [0x6f1c56]
	MessageLoop::Run() [0x6f1dac]
	TestShell::waitTestFinished() [0x43ea0d]
	TestShell::runFileTest() [0x43d498]
	runTest() [0x422fc3]
	main [0x42362c]
	0x7fbdd1b1cc4d
	0x419609
Comment 1 Adrienne Walker 2011-07-25 17:31:56 PDT
Committed r91729: <http://trac.webkit.org/changeset/91729>
Comment 2 Adrienne Walker 2011-07-26 11:17:34 PDT
Committed r91767: <http://trac.webkit.org/changeset/91767>
Comment 3 Adrienne Walker 2011-07-27 16:28:19 PDT
Committed r91881: <http://trac.webkit.org/changeset/91881>
Comment 4 Ami Fischman 2011-08-01 10:57:16 PDT
For the record, the problem here was a chromium media-stack bug; tracked in http://code.google.com/p/chromium/issues/detail?id=90214.  The offending CLs have been reverted, so probably the tests marked flaky as a result of *this* bug should be reverted.
Enne: since you're WK committer would you land this?  (simply removing the WK65155 lines from test_expectations.txt)
Comment 5 Ami Fischman 2011-08-01 14:35:58 PDT
Created attachment 102558 [details]
Patch
Comment 6 Ami Fischman 2011-08-01 14:36:18 PDT
*** Bug 65129 has been marked as a duplicate of this bug. ***
Comment 7 Adrienne Walker 2011-08-02 10:19:49 PDT
*** Bug 65149 has been marked as a duplicate of this bug. ***
Comment 8 Adrienne Walker 2011-08-02 10:22:23 PDT
*** Bug 65152 has been marked as a duplicate of this bug. ***
Comment 9 Adrienne Walker 2011-08-02 10:37:59 PDT
Committed r92205: <http://trac.webkit.org/changeset/92205>
Comment 10 Adrienne Walker 2011-08-02 10:38:51 PDT
(In reply to comment #9)
> Committed r92205: <http://trac.webkit.org/changeset/92205>

The landed patch is an expectations update for all the duped bugs.