Bug 65067 - CSS transition not animating height correct on hover
Summary: CSS transition not animating height correct on hover
Status: RESOLVED DUPLICATE of bug 16020
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://dev.ericperrets.info/css_issue...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-23 08:10 PDT by Eric
Modified: 2011-07-25 12:16 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2011-07-23 08:10:41 PDT
I have a page where I applied a transition to expand the height of a div when the mouse is moved over the div.  The CSS transition animation is shrinking the height to near zero using an animation and then it springs open to the expected height (with no animation).  Expected: The height of the div animates from current height to the full height (with no shrinking of size).

Steps to recreate it on the link, http://dev.ericperrets.info/css_issue/calendar/
Hovering the mouse over the "Sample title" or the "Sample title2" div causes the div to shrink to a hight of zero then expand (without any animation).
Comment 1 Simon Fraser (smfr) 2011-07-25 12:16:03 PDT
Sounds like the issue of animating to/from 'auto'.

*** This bug has been marked as a duplicate of bug 16020 ***