Bug 64985 - hook in the rest of the bots to the dashboard now they run NRWT
Summary: hook in the rest of the bots to the dashboard now they run NRWT
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ojan Vafai
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-21 15:38 PDT by Ojan Vafai
Modified: 2011-07-22 12:16 PDT (History)
0 users

See Also:


Attachments
Patch (1.65 KB, patch)
2011-07-21 15:39 PDT, Ojan Vafai
no flags Details | Formatted Diff | Diff
Patch (9.05 KB, patch)
2011-07-22 11:49 PDT, Ojan Vafai
abarth: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ojan Vafai 2011-07-21 15:38:44 PDT
hook in the rest of the bots to the dashboard now they run NRWT
Comment 1 Ojan Vafai 2011-07-21 15:39:04 PDT
Created attachment 101653 [details]
Patch
Comment 2 Ojan Vafai 2011-07-21 15:42:25 PDT
I'll commit this once the master has restarted and this all actually works. :)
Comment 3 Ojan Vafai 2011-07-22 11:49:42 PDT
Created attachment 101749 [details]
Patch
Comment 4 Adam Barth 2011-07-22 11:52:48 PDT
Comment on attachment 101749 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=101749&action=review

> Tools/TestResultServer/static-dashboards/flakiness_dashboard.html:322
> -var PLATFORMS = ['SNOWLEOPARD', 'LEOPARD', 'XP', 'VISTA', 'WIN7', 'LUCID'];
> +var PLATFORMS = ['SNOWLEOPARD', 'LEOPARD', 'XP', 'VISTA', 'WIN7', 'LUCID', 'APPLE_LEOPARD', 'APPLE_SNOWLEOPARD', 'APPLE_XP', 'APPLE_WIN7', 'GTK_LINUX', 'QT_LINUX'];

Should LEOPARD be CHROMIUM_LEOPARD ? (etc)

> Tools/TestResultServer/static-dashboards/flakiness_dashboard.html:526
> +function nonChromiumPlatform(builderNameUpperCase)

This doesn't seem like a function that should exist.

> Tools/TestResultServer/static-dashboards/flakiness_dashboard.html:542
> +function chromiumPlatform(builderNameUpperCase)

Why does chromium get special treatment?  It seems like Qt and Chromium would be similar in this regard.
Comment 5 Adam Barth 2011-07-22 11:58:44 PDT
Comment on attachment 101749 [details]
Patch

I'm marking this patch r+ because I feel like you're the owner of this code and you should set its direction.  This isn't the approach I would take because it feels like adding "non-chromium" as a special case rather that moving all the "chromium stuff" into chromium-specific names.  From a project-wide point of view, Chromium is a special case of WebKit, which is why we have things like chromium-mac and we should rename LayoutTests/platform/mac to LayoutTests/platform/apple-mac.  That's a somewhat larger project than what you're trying to accomplish here, and I can understand the value of getting something working as a base to start iterating from.
Comment 6 Ojan Vafai 2011-07-22 12:01:22 PDT
View in context: https://bugs.webkit.org/attachment.cgi?id=101749&action=review

>> Tools/TestResultServer/static-dashboards/flakiness_dashboard.html:322
>> +var PLATFORMS = ['SNOWLEOPARD', 'LEOPARD', 'XP', 'VISTA', 'WIN7', 'LUCID', 'APPLE_LEOPARD', 'APPLE_SNOWLEOPARD', 'APPLE_XP', 'APPLE_WIN7', 'GTK_LINUX', 'QT_LINUX'];
> 
> Should LEOPARD be CHROMIUM_LEOPARD ? (etc)

These are supposed to match whatever's in the test_expectations file. I have a FIXME in the test to figure out what we're doing with platform names in the test_expectations files. Maybe I should put a FIXME here as well?

>> Tools/TestResultServer/static-dashboards/flakiness_dashboard.html:542
>> +function chromiumPlatform(builderNameUpperCase)
> 
> Why does chromium get special treatment?  It seems like Qt and Chromium would be similar in this regard.

Chromium builders use a different naming convention than the non-chromium builders. These functions just map from builder name to platform. We could simplify this code by changing builder name conventions, but I'm not sure that's worth it.
Comment 7 Ojan Vafai 2011-07-22 12:16:39 PDT
Committed r91586: <http://trac.webkit.org/changeset/91586>