Bug 64663 - [Qt] Implement ShareableBitmap::paint() with scale factor
Summary: [Qt] Implement ShareableBitmap::paint() with scale factor
Status: RESOLVED DUPLICATE of bug 74010
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2011-07-16 21:04 PDT by Daniel Bates
Modified: 2011-12-07 10:45 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bates 2011-07-16 21:04:56 PDT
Implement the scale factor variant of ShareableBitmap::paint(). One such usage of this variant is in changeset <http://trac.webkit.org/changeset/91085>. In particular, the change to Source/WebKit2/UIProcess/FindIndicator.cpp.
Comment 1 Daniel Bates 2011-07-16 21:06:28 PDT
For completeness, the scale factor variant of ShareableBitmap::paint() was added to the CG port in <http://trac.webkit.org/changeset/90198>.
Comment 2 Daniel Bates 2011-07-16 21:22:18 PDT
The Qt Linux Release build fails to compile because this variant of ShareableBitmap::paint() wasn't implemented for the Qt WebKit2 port at the time changeset 91085 <http://trac.webkit.org/changeset/91085> landed:

[[
../../WebKit2/release/libwebkit2.a(FindIndicator.o): In function `WebKit::FindIndicator::draw(WebCore::GraphicsContext&, WebCore::IntRect const&)':
FindIndicator.cpp:(.text._ZN6WebKit13FindIndicator4drawERN7WebCore15GraphicsContextERKNS1_7IntRectE+0xf3): undefined reference to `WebKit::ShareableBitmap::paint(WebCore::GraphicsContext&, float, WebCore::IntPoint const&, WebCore::IntRect const&)'
collect2: ld returned 1 exit status
make[1]: *** [../../lib/libQtWebKit.so.4.10.0] Error 1
make[1]: Leaving directory `/ramdisk/qt-linux-release/build/WebKitBuild/Release/WebKit/qt'
make: *** [sub-WebKit-qt-QtWebKit-pro-make_default-ordered] Error 2
]]

See <http://build.webkit.org/builders/Qt%20Linux%20Release/builds/35470/steps/compile-webkit/logs/stdio> for more details.

Committed stub method in <http://trac.webkit.org/changeset/91162>.
Comment 3 Balazs Kelemen 2011-12-07 10:45:18 PST

*** This bug has been marked as a duplicate of bug 74010 ***