Bug 64439 - WIN: NRWT has incorrect fallback for win port
Summary: WIN: NRWT has incorrect fallback for win port
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Eric Seidel (no email)
URL:
Keywords:
: 64469 (view as bug list)
Depends on: 64486
Blocks: 38756
  Show dependency treegraph
 
Reported: 2011-07-13 02:13 PDT by Eric Seidel (no email)
Modified: 2011-08-09 15:19 PDT (History)
4 users (show)

See Also:


Attachments
Patch (49.53 KB, patch)
2011-07-13 03:32 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2011-07-13 02:13:25 PDT
new-run-webkit-tests has incorrect fallback for win port
Comment 1 Eric Seidel (no email) 2011-07-13 03:32:49 PDT
Created attachment 100650 [details]
Patch
Comment 2 Eric Seidel (no email) 2011-07-13 03:33:04 PDT
Comment on attachment 100650 [details]
Patch

This is really a wip patch.
Comment 3 WebKit Review Bot 2011-07-13 03:35:03 PDT
Attachment 100650 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Tools/ChangeLog', u'Tools/Scripts/webkitpy..." exit_code: 1

Tools/Scripts/webkitpy/layout_tests/port/base.py:560:  at least two spaces before inline comment  [pep8/E261] [5]
Total errors found: 1 in 18 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Eric Seidel (no email) 2011-07-13 11:21:32 PDT
*** Bug 64469 has been marked as a duplicate of this bug. ***
Comment 5 Adam Roben (:aroben) 2011-07-13 11:29:27 PDT
Comment on attachment 100650 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=100650&action=review

> Tools/Scripts/webkitpy/layout_tests/port/win.py:58
> +        if not hasattr(sys, 'getwindowsversion'):

Cygwin's Python doesn't have sys.getwindowsversion(), so this won't work as-is for Apple's Windows port.
Comment 6 Eric Seidel (no email) 2011-07-13 14:00:05 PDT
I guess we'll have to make our own wrapper around GetVersionEx then?
Comment 7 Eric Seidel (no email) 2011-07-13 14:00:49 PDT
We should be able to build such with ctypes:
http://docs.python.org/library/ctypes.html

But I think that may be beyond my ability without having a windows machine easily accessible.
Comment 8 Adam Roben (:aroben) 2011-07-13 14:10:16 PDT
(In reply to comment #6)
> I guess we'll have to make our own wrapper around GetVersionEx then?

Or we could run `cmd /c ver`, like ORWT does.
Comment 9 Eric Seidel (no email) 2011-08-09 15:16:26 PDT
I think this just ended up a duplicate of bug 64486
Comment 10 Eric Seidel (no email) 2011-08-09 15:19:17 PDT
Much of the factory stuff and SUPPORTED_OS_VERSIONS code has been replaced by the new TestConfiguration stuff.  I think we can close this as fixed or duplicate.