Bug 64433 - Improve names of some ApplicationCacheStorage accessor methods
Summary: Improve names of some ApplicationCacheStorage accessor methods
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
Depends on:
Reported: 2011-07-12 22:10 PDT by Joseph Pecoraro
Modified: 2011-07-13 14:42 PDT (History)
2 users (show)

See Also:

[PATCH] Rename the functions (11.92 KB, patch)
2011-07-12 22:28 PDT, Joseph Pecoraro
ap: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2011-07-12 22:10:39 PDT
In an earlier patch review Alexey mentioned:

> > Source/WebCore/loader/appcache/ApplicationCacheGroup.cpp:827
> > +        // Failed to determine what is left in the quota. Fallback to allowing anything. 
> It's a bad coding style violation that a function called remainingSizeForOriginExcludingCache()
> returns a boolean, not the remaining size. This is a pre-existing issue, and not something you
> did in this patch.

There are a few functions that should be updated:

  quotaForOrigin, usageForOrigin, and remainingSizeForOriginExcludingCache

I'll fix them with the suggested rename calculate...()
Comment 1 Joseph Pecoraro 2011-07-12 22:28:43 PDT
Created attachment 100629 [details]
[PATCH] Rename the functions
Comment 2 Joseph Pecoraro 2011-07-13 14:42:55 PDT
Landed in r90948 <http://trac.webkit.org/changeset/90948>.