Bug 64326 - Change roundedIntRect to roundedRect
Summary: Change roundedIntRect to roundedRect
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Levi Weintraub
URL:
Keywords:
Depends on:
Blocks: 63567
  Show dependency treegraph
 
Reported: 2011-07-11 16:46 PDT by Levi Weintraub
Modified: 2011-07-12 11:55 PDT (History)
8 users (show)

See Also:


Attachments
Patch (90.29 KB, patch)
2011-07-11 17:32 PDT, Levi Weintraub
no flags Details | Formatted Diff | Diff
Patch for landing (91.62 KB, patch)
2011-07-12 10:16 PDT, Levi Weintraub
no flags Details | Formatted Diff | Diff
Patch for landing (108.47 KB, patch)
2011-07-12 11:11 PDT, Levi Weintraub
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Levi Weintraub 2011-07-11 16:46:02 PDT
roundedIntRect should be based on Layout units, so I'm renaming it to "roundedRect"
Comment 1 Levi Weintraub 2011-07-11 17:32:54 PDT
Created attachment 100390 [details]
Patch
Comment 2 Eric Seidel (no email) 2011-07-11 17:42:34 PDT
Comment on attachment 100390 [details]
Patch

Seems OK.  Could also be RoundedLayoutRect.
Comment 3 Simon Fraser (smfr) 2011-07-11 17:43:54 PDT
Actually I think when used in GraphicsContext methods, it should always be a float-based.
Comment 4 Gyuyoung Kim 2011-07-11 18:00:39 PDT
Comment on attachment 100390 [details]
Patch

Attachment 100390 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/9009779
Comment 5 Gustavo Noronha (kov) 2011-07-11 18:11:16 PDT
Comment on attachment 100390 [details]
Patch

Attachment 100390 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/9012651
Comment 6 Levi Weintraub 2011-07-12 10:16:07 PDT
Created attachment 100506 [details]
Patch for landing
Comment 7 Levi Weintraub 2011-07-12 10:19:06 PDT
(In reply to comment #3)
> Actually I think when used in GraphicsContext methods, it should always be a float-based.

I think you're right. We plan on auditing all the rounding as part of our process. It'll be one of the most fun parts :)
Comment 8 Levi Weintraub 2011-07-12 10:45:02 PDT
Comment on attachment 100506 [details]
Patch for landing

Just realized I missed one more file. Fixing and re-uploading.
Comment 9 Levi Weintraub 2011-07-12 11:11:02 PDT
Created attachment 100525 [details]
Patch for landing
Comment 10 WebKit Review Bot 2011-07-12 11:37:24 PDT
Comment on attachment 100525 [details]
Patch for landing

Clearing flags on attachment: 100525

Committed r90832: <http://trac.webkit.org/changeset/90832>
Comment 11 WebKit Review Bot 2011-07-12 11:37:29 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Darin Adler 2011-07-12 11:39:23 PDT
This is a layer violation.

Layout units is a higher level concept in the rendering engine, not one that should exist at the platform level.

If we can move to floating point for the rounded rectangle arguments for graphics context arguments, then we should do so. It seems like a very bad idea to have the graphics context layer be built on top of the layout units concept.
Comment 13 Simon Fraser (smfr) 2011-07-12 11:55:47 PDT
Agree with Darin