Bug 64205 - With NRWT, many plugin-related tests fail
Summary: With NRWT, many plugin-related tests fail
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
Depends on:
Reported: 2011-07-08 14:34 PDT by Simon Fraser (smfr)
Modified: 2011-07-12 14:56 PDT (History)
3 users (show)

See Also:

Webarchive of results (186.46 KB, application/x-webarchive)
2011-07-08 14:34 PDT, Simon Fraser (smfr)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2011-07-08 14:34:05 PDT
I see lots of plugin-related tests failing with NRWT, in a Mac debug build on SnowLeopard. TestNetscapePlugIn.plugin exists in my WebKitBuild/Debug dir. I'm running with the --debug flag.
Comment 1 Simon Fraser (smfr) 2011-07-08 14:34:43 PDT
Created attachment 100165 [details]
Webarchive of results

Attached results from a debug build at r90640.
Comment 2 Adam Barth 2011-07-08 14:35:11 PDT
Thanks Simon.
Comment 3 Simon Fraser (smfr) 2011-07-08 14:38:36 PDT
DRT has addTestPluginsToPluginSearchPath().
Comment 4 Eric Seidel (no email) 2011-07-09 03:42:49 PDT
Thanks!  I'll take a look this weekend.
Comment 5 Eric Seidel (no email) 2011-07-10 12:05:21 PDT

% new-run-webkit-tests plugins
All 105 tests ran as expected.

All plugin tests pass for me on my machine.

I can't see the diffs from your run.  BUt if you zip up your /tmp/layout-test-results directory after a run, I'm happy to take a look.
Comment 6 Eric Seidel (no email) 2011-07-10 12:08:09 PDT
static void addTestPluginsToPluginSearchPath(const char* executablePath)
    NSString *pwd = [[NSString stringWithUTF8String:executablePath] stringByDeletingLastPathComponent];
    [WebPluginDatabase setAdditionalWebPlugInPaths:[NSArray arrayWithObject:pwd]];
    [[WebPluginDatabase sharedDatabase] refresh];

Is the function you referenced before.  It adds the build directory of DRT to the plugin search path.  Which looks correct.

Are you running new-run-webkit-tests directly (or is run-webkit-tests calling it for you?)

I assume you're running the tests with WebKit1?  (Right now run-webkit-tests will call old-run-webkit-tests if you run it for WebKit2, since NRWT's WebKit2 support isn't quite done yet.  See bug 56729.)
Comment 7 Eric Seidel (no email) 2011-07-10 12:10:06 PDT
I tried deleting TestNetscapePlugin.plugin from my build directory, and NRWT correctly re-built it (I suspect it might not know how to, but it did!)
Comment 8 Eric Seidel (no email) 2011-07-10 12:11:29 PDT
I tried executing new-run-webkit-tests --debug plugins (explicitly adding the --debug flag in case that might confuse things) but that didn't repro the failures either. :(
Comment 9 Eric Seidel (no email) 2011-07-10 12:11:51 PDT
I'm testing on:
ProductName:	Mac OS X
ProductVersion:	10.6.8
BuildVersion:	10K540
Comment 10 Eric Seidel (no email) 2011-07-10 12:18:47 PDT
For completeness, I should mention I was testing with r90548.
Comment 11 Simon Fraser (smfr) 2011-07-10 22:47:46 PDT
I'll investigate.
Comment 12 Simon Fraser (smfr) 2011-07-12 14:56:42 PDT
I had a broken symlink in ~/Library/Internet Plugins