Bug 6404 - Deployment build fails on TOT?
Summary: Deployment build fails on TOT?
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P1 Blocker
Assignee: Nobody
URL:
Keywords:
: 6405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-06 19:19 PST by Eric Seidel (no email)
Modified: 2006-01-31 21:20 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-01-06 19:19:00 PST
On Jan 6, 2006, at 4:40 PM, Chris Petersen wrote:

I ran into a build error this morning when attempting to build as Deployment on the iMac. Anyone know 
why this is ?

    setenv MACOSX_DEPLOYMENT_TARGET 10.3
    /usr/bin/g++-3.3 -o /Volumes/fresh_10.4.2/Build/symroots/Deployment/WebCore.framework/
Versions/A/WebCore -L/Volumes/fresh_10.4.2/Build/symroots/Deployment -L/Volumes/fresh_10.4.2/
Build/symroots/WebCore.build/Deployment/WebCore.build/DerivedSources -F/Volumes/fresh_10.4.2/
Build/symroots/Deployment -F/System/Library/Frameworks/WebKit.framework/Frameworks -filelist /
Volumes/fresh_10.4.2/Build/symroots/WebCore.build/Deployment/WebCore.build/Objects-normal/
ppc/WebCore.LinkFileList -framework ApplicationServices -framework Carbon -framework Cocoa -
framework JavaScriptCore -licucore -lxslt -framework QuartzCore -arch ppc -Wl,-single_module -
compatibility_version 1 -current_version 1 -install_name /System/Library/Frameworks/
WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore -dynamiclib -
mmacosx-version-min=10.3 -lxml2-WebCore -Wl,-exported_symbols_list,WebCore.exp
ld: mismatching weak references for symbol: _CGBitmapContextCreateImage
/Volumes/fresh_10.4.2/Build/symroots/WebCore.build/Deployment/WebCore.build/Objects-normal/
ppc/kjs_html.o reference to non-weak _CGBitmapContextCreateImage
/Volumes/fresh_10.4.2/Build/symroots/WebCore.build/Deployment/WebCore.build/Objects-normal/
ppc/render_canvasimage.o reference to non-weak _CGBitmapContextCreateImage
/Volumes/fresh_10.4.2/Build/symroots/WebCore.build/Deployment/WebCore.build/Objects-normal/
ppc/KCanvasMaskerQuartz.o reference to weak _CGBitmapContextCreateImage
/usr/bin/libtool: internal link edit command failed
** BUILD FAILED **
make[1]: *** [all-am] Error 1
il0301a-dhcp17:/Build/Labyrinth chrispet$

My guess is that this has something to do with the way we declare CGBitmapContextCreateImage 
ourselves in render_canvasimage.h. I imagine this would go away if we set 
MACOSX_DEPLOYMENT_TARGET to 10.4 or if we just used the definition in the system header and 
removed our own declaration.

Eric's the best person to ask about this.

Also, we should see if this is failing for everyone.

    -- Darin

========

This was caused by my check-in of 
http://bugzilla.opendarwin.org/show_bug.cgi?id=5969
Comment 1 Maciej Stachowiak 2006-01-07 14:59:03 PST
I'm seeing the same problem on Development.
Comment 2 Eric Seidel (no email) 2006-01-07 14:59:09 PST
*** Bug 6405 has been marked as a duplicate of this bug. ***
Comment 3 Joost de Valk (AlthA) 2006-01-22 04:57:46 PST
Removing keyword(s) since bug is fixed.
Comment 4 Joost de Valk (AlthA) 2006-01-22 04:59:17 PST
Removing keyword(s) since bug is fixed. And now for real.
Comment 5 Joost de Valk (AlthA) 2006-01-22 05:01:38 PST
Removing keyword(s) since bug is fixed.
Comment 6 Eric Seidel (no email) 2006-01-31 21:20:42 PST
Removing Regression keyword from bugs already fixed.