Bug 6393 - Per SGML spec, </b<br> should be treated as </b><br>
Summary: Per SGML spec, </b<br> should be treated as </b><br>
Status: RESOLVED DUPLICATE of bug 8016
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML DOM (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.3
: P2 Normal
Assignee: Nobody
URL: data:text/html,<b>foo</b<br>bar
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-05 21:33 PST by timeless
Modified: 2007-04-03 06:53 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description timeless 2006-01-05 21:33:38 PST
Steps to reproduce:
1. load data:text/html,<b>foo</b><br>bar
2. load data:text/html,<b>foo</b<br>bar

Actual Results:
Second url doesn't render the same as first, but instead renders as:
{bold}foobar{/bold}

data:text/html,<b>foobar</b>

Seen in:
Safari 1.3.1 (v312.3.3) on OS X 10.3.9

Expected Results:
{bold}foo{/bold}
{break}bar

It should appear the same as:
data:text/html,<b>foo</b><br>bar

- Also Occurs On
Safari 2.0.2 (416.13) on OS X 10.4.3 8F46

- Doesn't Occur On
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051224
Camino/1.0+
Mozilla/4.0 (compatible; MSIE 5.23; Mac_PowerPC) build 5815.1
Comment 1 Joost de Valk (AlthA) 2006-01-11 05:51:01 PST
Confirmed :)
Comment 2 Alexey Proskuryakov 2007-04-03 06:53:43 PDT
Fixed with bug 8016.

*** This bug has been marked as a duplicate of 8016 ***