Bug 63905 - Events do not work on created documents
Summary: Events do not work on created documents
Status: RESOLVED DUPLICATE of bug 26147
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-04 07:07 PDT by David Rivron
Modified: 2011-07-05 00:13 PDT (History)
2 users (show)

See Also:


Attachments
Test case (841 bytes, application/xhtml+xml)
2011-07-04 07:07 PDT, David Rivron
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Rivron 2011-07-04 07:07:06 PDT
Created attachment 99626 [details]
Test case

Documents created by document.implementation.createDocument or XMLHttpRequest do not handle events.

Expected result of the test case (in the console):
true
foo
DOMNodeRemoved

Actual result:
true
Comment 1 Alexey Proskuryakov 2011-07-05 00:12:31 PDT

*** This bug has been marked as a duplicate of bug 26147 ***
Comment 2 Alexey Proskuryakov 2011-07-05 00:13:42 PDT
Note that DOMNodeRemoved wouldn't fire in a normal document either - see e.g. bug 55666.