Bug 63848 - Consider backing scale when setting up graphics layers
Summary: Consider backing scale when setting up graphics layers
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Darin Adler
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-07-01 14:29 PDT by Darin Adler
Modified: 2011-07-01 16:13 PDT (History)
0 users

See Also:


Attachments
Patch (8.77 KB, patch)
2011-07-01 14:34 PDT, Darin Adler
no flags Details | Formatted Diff | Diff
Patch (9.24 KB, patch)
2011-07-01 16:09 PDT, Darin Adler
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2011-07-01 14:29:19 PDT
Consider backing scale factor when setting up graphics layers
Comment 1 Darin Adler 2011-07-01 14:34:12 PDT
Created attachment 99524 [details]
Patch
Comment 2 Darin Adler 2011-07-01 14:34:53 PDT
<rdar://problem/8669917>
Comment 3 Simon Fraser (smfr) 2011-07-01 14:42:08 PDT
Comment on attachment 99524 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=99524&action=review

> Source/WebCore/rendering/RenderLayerBacking.cpp:111
> +    ASSERT(renderer());
> +    ASSERT(renderer()->document());
> +    ASSERT(renderer()->document()->frame());

Should these be moved to pageContentsScale()?

> Source/WebCore/rendering/RenderLayerBacking.h:195
> +    float pageContentsScale() const;

Why not just call this pageScaleFactor() to avoid introducing another term?
Comment 4 Darin Adler 2011-07-01 14:55:28 PDT
Comment on attachment 99524 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=99524&action=review

>> Source/WebCore/rendering/RenderLayerBacking.cpp:111
>> +    ASSERT(renderer()->document()->frame());
> 
> Should these be moved to pageContentsScale()?

Probably not. At other call sites it may be OK for some of these things to be null.

>> Source/WebCore/rendering/RenderLayerBacking.h:195
>> +    float pageContentsScale() const;
> 
> Why not just call this pageScaleFactor() to avoid introducing another term?

Will do.
Comment 5 Darin Adler 2011-07-01 16:09:19 PDT
Created attachment 99534 [details]
Patch
Comment 6 Darin Adler 2011-07-01 16:13:32 PDT
Committed r90293: <http://trac.webkit.org/changeset/90293>