RESOLVED FIXED Bug 63640
Switch RenderLayer::hitTest* to to new layout types
https://bugs.webkit.org/show_bug.cgi?id=63640
Summary Switch RenderLayer::hitTest* to to new layout types
Emil A Eklund
Reported 2011-06-29 11:42:01 PDT
Convert RenderLayer hit testing functions to new layout types.
Attachments
Patch (17.37 KB, patch)
2011-06-29 11:54 PDT, Emil A Eklund
no flags
Patch (17.44 KB, patch)
2011-06-30 13:37 PDT, Emil A Eklund
no flags
Emil A Eklund
Comment 1 2011-06-29 11:54:12 PDT
Eric Seidel (no email)
Comment 2 2011-06-29 12:05:55 PDT
Comment on attachment 99119 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=99119&action=review > Source/WebCore/rendering/LayoutTypes.h:51 > + return roundedIntPoint(point); Is this always what we want?
Emil A Eklund
Comment 3 2011-06-29 12:07:28 PDT
> Is this always what we want? No. Perhaps roundedLayoutPoint would be a better name?
Emil A Eklund
Comment 4 2011-06-30 13:37:07 PDT
Eric Seidel (no email)
Comment 5 2011-06-30 13:50:56 PDT
Comment on attachment 99362 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=99362&action=review > Source/WebCore/rendering/LayoutTypes.h:52 > +inline LayoutPoint roundedLayoutPoint(FloatPoint point) > +{ > + return roundedIntPoint(point); > +} These methods scare me. What is this going to do when you move LayoutPoint to float? Is it going to still round?
Emil A Eklund
Comment 6 2011-06-30 13:52:35 PDT
(In reply to comment #5) > These methods scare me. What is this going to do when you move LayoutPoint to float? Is it going to still round? No, I tried to explain the rational in the change log. Once we switch to float or fixed those methods will be no-ops. They're only used in placed where we do rounding today where we won't have to do rounding in the future.
Eric Seidel (no email)
Comment 7 2011-06-30 13:53:28 PDT
Won't there also be cases where we want to round in both worlds? How will we separate those?
Emil A Eklund
Comment 8 2011-06-30 13:59:11 PDT
(In reply to comment #7) > Won't there also be cases where we want to round in both worlds? How will we separate those? There might be. For those we plan to move the rounding into semantically meaningful helper methods on one of the the rendering base classes. The roundedLayout* methods used in this and my other pending patches are all for cases where we do not want to do rounding going forward. Perhaps we should try to make this clearer by naming them something else? I'm not sure what that name would be though.
Emil A Eklund
Comment 9 2011-07-06 08:57:59 PDT
Eric, any suggestions?
Eric Seidel (no email)
Comment 10 2011-07-06 12:58:38 PDT
Comment on attachment 99362 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=99362&action=review >> Source/WebCore/rendering/LayoutTypes.h:52 >> +} > > These methods scare me. What is this going to do when you move LayoutPoint to float? Is it going to still round? I'm OK with this, assuming you all plan to audit all these callsites at some point.
Emil A Eklund
Comment 11 2011-07-06 13:05:05 PDT
Yay, thanks Eric. Filed bug 64021 to audit all the callsites when we make the switch.
WebKit Review Bot
Comment 12 2011-07-06 13:20:18 PDT
Comment on attachment 99362 [details] Patch Clearing flags on attachment: 99362 Committed r90485: <http://trac.webkit.org/changeset/90485>
WebKit Review Bot
Comment 13 2011-07-06 13:20:22 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.