Bug 63477 - WebKitTestRunner needs an implemenation of allowRoundingHacks
Summary: WebKitTestRunner needs an implemenation of allowRoundingHacks
Status: RESOLVED DUPLICATE of bug 87328
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://build.webkit.org/results/SnowL...
Keywords: InRadar, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2011-06-27 13:48 PDT by Jessie Berlin
Modified: 2013-04-17 14:45 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jessie Berlin 2011-06-27 13:48:40 PDT
platform/mac/fast/text/rounding-hacks.html started failing on SnowLeopard Intel Release (WebKit2 Tests) in r89733 <http://trac.webkit.org/changeset/89733>.

http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(WebKit2%20Tests)/r89732%20(12906)/results.html passed
http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(WebKit2%20Tests)/r89733%20(12907)/results.html failed

This is because no implementation of allowRoundingHacks was added to WKTR. The test should be added to the skipped list for now.
Comment 1 Jessie Berlin 2011-06-27 13:54:14 PDT
<rdar://problem/9683758>
Comment 2 Adam Roben (:aroben) 2011-08-17 08:06:27 PDT
These tests are now being skipped.
Comment 3 Jessie Berlin 2013-04-17 14:45:40 PDT
allowRoundingHacks was moved to Internals in http://trac.webkit.org/changeset/118657 for https://bugs.webkit.org/show_bug.cgi?id=87328

*** This bug has been marked as a duplicate of bug 87328 ***