Bug 63343 - REGRESSION (r89687): 5 compositing/rtl tests failing on Windows 7 Release (Tests)
Summary: REGRESSION (r89687): 5 compositing/rtl tests failing on Windows 7 Release (Te...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows 7
: P2 Normal
Assignee: Adrienne Walker
URL: http://build.webkit.org/results/Windo...
Keywords: LayoutTestFailure, MakingBotsRed, Regression
Depends on:
Blocks:
 
Reported: 2011-06-24 12:57 PDT by Adam Roben (:aroben)
Modified: 2011-06-24 15:15 PDT (History)
3 users (show)

See Also:


Attachments
Patch (11.42 KB, patch)
2011-06-24 15:08 PDT, Adrienne Walker
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2011-06-24 12:57:43 PDT
The following tests have been failing on Windows 7 Release (Tests) since r89687:

    compositing/rtl/rtl-iframe-absolute-overflow.html
    compositing/rtl/rtl-iframe-absolute.html
    compositing/rtl/rtl-iframe-fixed-overflow.html
    compositing/rtl/rtl-iframe-fixed.html
    compositing/rtl/rtl-iframe-relative.html

http://build.webkit.org/results/Windows%207%20Release%20(Tests)/r89686%20(14134)/results.html passed
http://build.webkit.org/results/Windows%207%20Release%20(Tests)/r89687%20(14135)/results.html failed
Comment 1 Adam Roben (:aroben) 2011-06-24 12:58:57 PDT
All the failure diffs show two layers that are either 44px or 45px too short.
Comment 2 Brian Weinstein 2011-06-24 13:25:35 PDT
These tests were skipped on Mac when they landed, with a comment.

# https://bugs.webkit.org/show_bug.cgi?id=63282 layerTreeAsText doesn't work for iframes

Do we need to do the same for Windows?
Comment 3 Adrienne Walker 2011-06-24 13:39:32 PDT
Windows should probably be marked skipped as well.  I'll take care of this.
Comment 4 Adrienne Walker 2011-06-24 13:58:00 PDT
(In reply to comment #3)
> Windows should probably be marked skipped as well.  I'll take care of this.

Actually, scratch that.  Looking at the results, bug 63282 doesn't seem applicable.  There were no results at all on Snow Leopard, which is why I skipped them there.  However, there are results here so they shouldn't be skipped.

I suspect the issue is font metric differences on the element containing the layerTreeAsText output that are showing up in the graphics layer tree.

Is there a better way to get layerTreeAsText dumps that don't change the pixel results and also don't change the output of the graphics layer tree? I put them offscreen at 10000px in a <pre> tag, but they got composited when put into an iframe.

Should I just make this element use the Ahem font or is there some better way to be doing this?
Comment 5 Simon Fraser (smfr) 2011-06-24 14:00:20 PDT
Do you care about the render tree dump? You could dumpAsText(true).
Comment 6 Adrienne Walker 2011-06-24 14:04:20 PDT
(In reply to comment #5)
> Do you care about the render tree dump? You could dumpAsText(true).

I am doing that already.

The problem is that I have a test that adds layerTreeAsText into a <pre> element.  Then I include that test in an iframe which gets composited in a second test.  The element bounds with the text of the iframe's layer tree affects the graphics layer tree of the containing second test, which is why this is failing here.
Comment 7 Simon Fraser (smfr) 2011-06-24 14:14:18 PDT
Give the iframe document's body a fixed height with overflow:hidden?
Comment 8 Adrienne Walker 2011-06-24 15:08:39 PDT
Created attachment 98548 [details]
Patch
Comment 9 Adrienne Walker 2011-06-24 15:15:40 PDT
Committed r89709: <http://trac.webkit.org/changeset/89709>