Bug 63299 - Button element doesn't fire 'focus' or 'blur' events
Summary: Button element doesn't fire 'focus' or 'blur' events
Status: RESOLVED DUPLICATE of bug 22261
Alias: None
Product: WebKit
Classification: Unclassified
Component: Event Handling (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows 7
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, NeedsRadar
Depends on:
Blocks:
 
Reported: 2011-06-23 16:07 PDT by Corey
Modified: 2011-06-23 22:45 PDT (History)
9 users (show)

See Also:


Attachments
HTML document demonstrating button events (619 bytes, text/html)
2011-06-23 16:07 PDT, Corey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Corey 2011-06-23 16:07:39 PDT
Created attachment 98424 [details]
HTML document demonstrating button events

Attached test case. You'll see in Firefox or Internet Explorer that both the focus and blur events are fired. But not in Chrome or Safari (Webkit).
Comment 1 Emil A Eklund 2011-06-23 16:13:08 PDT
Interestingly it fires focus/blur correctly if focused using the keyboard (tab).
Comment 2 Daniel Bates 2011-06-23 16:14:22 PDT
This bug seems related to bug #22261.
Comment 3 Ryosuke Niwa 2011-06-23 16:21:49 PDT
Apparently, Mac doesn't have the concept of mouse-focused-button :(
Comment 4 Alexey Proskuryakov 2011-06-23 19:16:53 PDT
> This bug seems related to bug #22261.

I think that it's a duplicate.
Comment 5 Antonio Gomes 2011-06-23 19:55:01 PDT
But that one is not Window 7 specific. It happens on all ports except Qt and Gtk.
Comment 6 Daniel Bates 2011-06-23 22:45:21 PDT
(In reply to comment #5)
> But that one is not Window 7 specific. It happens on all ports except Qt and Gtk.

This bug isn't Windows 7 specific. Corey mentioned on IRC that he was using Windows 7. Hence I marked it as such.

After looking over the description and test case for bug #22261, and based on Alexey's assessment (comment 4), I am marking this bug as duplicate of bug #22261. If anyone feels that this bug isn't a duplicate then feel free to reopen it.

*** This bug has been marked as a duplicate of bug 22261 ***