Bug 63268 - http/tests/multipart/win-boundary-crash.html flakey
Summary: http/tests/multipart/win-boundary-crash.html flakey
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Fujii Hironori
URL: http://build.webkit.org/results/Windo...
Keywords: InRadar, LayoutTestFailure, PlatformOnly, Regression
Depends on:
Blocks:
 
Reported: 2011-06-23 11:36 PDT by Jessie Berlin
Modified: 2023-10-24 18:57 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Jessie Berlin 2011-06-23 11:43:54 PDT
Added to the Windows skipped list in http://trac.webkit.org/changeset/89596
Comment 3 Adam Roben (:aroben) 2011-06-23 12:32:47 PDT
(In reply to comment #2)
> I will move the entry to the mac Skipped list.

Seems like you need it to be on both mac/Skipped and win/Skipped. (Windows WebKit1 doesn't use mac/Skipped.)

Or maybe we should disable the test by renaming it.
Comment 4 Jessie Berlin 2011-06-23 12:35:14 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > I will move the entry to the mac Skipped list.
> 
> Seems like you need it to be on both mac/Skipped and win/Skipped. (Windows WebKit1 doesn't use mac/Skipped.)
> 
> Or maybe we should disable the test by renaming it.

I thought the win skipped list always inherited from the mac skipped list.

Moved to the mac skipped list in http://trac.webkit.org/changeset/89600.
Comment 5 Jessie Berlin 2011-06-23 12:52:35 PDT
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > I will move the entry to the mac Skipped list.
> > 
> > Seems like you need it to be on both mac/Skipped and win/Skipped. (Windows WebKit1 doesn't use mac/Skipped.)
> > 
> > Or maybe we should disable the test by renaming it.
> 
> I thought the win skipped list always inherited from the mac skipped list.
> 
> Moved to the mac skipped list in http://trac.webkit.org/changeset/89600.

Adam showed me that it was not, so I went ahead and just disabled the test in http://trac.webkit.org/changeset/89602
Comment 6 Tony Chang 2011-06-23 16:10:11 PDT
This is super weird.  Here's the test html:
http://trac.webkit.org/browser/trunk/LayoutTests/http/tests/multipart/win-boundary-crash.html-disabled

1       <html>
2	<head>
3	<script>
4	    if (window.layoutTestController)
5	        layoutTestController.dumpAsText();
6	</script>
7	</head>
8	<body>
9	<p>Test for <i><a href="http://bugs.webkit.org/show_bug.cgi?id=14516">http://bugs.webkit.org/show_bug.cgi?id=14516</a>
10	crash loading multipart/x-mixed-replace data on windows safari</i></p>
11	<p>If WebKit does not crash when loading this img, then it passed.</p>
12	<img src="resources/multipart-nodashes.php" />
13	</body>
14	</html>

The diff shows that dumpAsText() didn't get called, but I don't see how that's possible.

cc'ing abarth since this sounds similar to https://bugs.webkit.org/show_bug.cgi?id=63057 .
Comment 7 Adam Roben (:aroben) 2011-06-24 09:00:09 PDT
(In reply to comment #6)
> The diff shows that dumpAsText() didn't get called, but I don't see how that's possible.

No, the diff shows that the some other test got dumped instead. Look more closely and you'll see that the text is entirely different.
Comment 8 Tony Chang 2011-06-24 10:23:31 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > The diff shows that dumpAsText() didn't get called, but I don't see how that's possible.
> 
> No, the diff shows that the some other test got dumped instead. Look more closely and you'll see that the text is entirely different.

Ah, sorry, you're right, it's the output from the previous test (stop-crash.html).  This could be a problem with ORWT or maybe one of the previous tests has an http connection that's hanging or something.
Comment 9 Fujii Hironori 2023-10-23 16:53:56 PDT
Pull request: https://github.com/WebKit/WebKit/pull/19461
Comment 10 EWS 2023-10-24 00:24:09 PDT
Test gardening commit 269704@main (237bd74e5ced): <https://commits.webkit.org/269704@main>

Reviewed commits have been landed. Closing PR #19461 and removing active labels.
Comment 11 Fujii Hironori 2023-10-24 18:56:53 PDT
No flaky after 269704@main.
https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2Fmultipart%2Fwin-boundary-crash.html

Filed a new ticket for the GTK and WPE crashes.
  Bug 263629 – [GTK][WPE] http/tests/multipart/win-boundary-crash.html is crashing: soup_multipart_input_stream_read_headers: assertion 'got_lf' failed
Comment 12 Radar WebKit Bug Importer 2023-10-24 18:57:15 PDT
<rdar://problem/117447848>