Bug 63196 - Make Chromium Mac and Linux tests bot core builders
Summary: Make Chromium Mac and Linux tests bot core builders
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-22 15:45 PDT by Ryosuke Niwa
Modified: 2011-07-11 19:17 PDT (History)
7 users (show)

See Also:


Attachments
Patch (7.89 KB, patch)
2011-06-22 15:53 PDT, Ryosuke Niwa
abarth: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2011-06-22 15:45:38 PDT
Chromium Mac and Linux Tests bots have been stable for the last couple of weeks.  We should make them core builders.
Comment 1 Eric Seidel (no email) 2011-06-22 15:48:30 PDT
Sounds great!
Comment 2 Adam Barth 2011-06-22 15:50:16 PDT
http://build.webkit.org/builders/Chromium%20Mac%20Release%20%28Tests%29?numbuilds=200

says that Make Chromium Mac and Linux tests bot core builders has been red about 40% of the time in the last 200 runs.

http://build.webkit.org/builders/Chromium%20Linux%20Release%20%28Tests%29?numbuilds=200

says that Chromium Linux has been green less than 50% of the last 200 runs.
Comment 3 Ryosuke Niwa 2011-06-22 15:53:50 PDT
Created attachment 98255 [details]
Patch
Comment 4 Ryosuke Niwa 2011-06-22 16:00:36 PDT
(In reply to comment #2)
> http://build.webkit.org/builders/Chromium%20Mac%20Release%20%28Tests%29?numbuilds=200
> 
> says that Make Chromium Mac and Linux tests bot core builders has been red about 40% of the time in the last 200 runs.

which might be better than Snow Leopard:
http://build.webkit.org/builders/SnowLeopard%20Intel%20Release%20(Tests)?numbuilds=200
Comment 5 Ryosuke Niwa 2011-06-22 16:03:42 PDT
Also comparable to Qt Release:
http://build.webkit.org/builders/Qt%20Linux%20Release?numbuilds=200
Comment 6 Adam Barth 2011-06-22 16:09:50 PDT
Yes.  We should remove those from the list of core builders, IMHO.  The core page is too red now to be useful.
Comment 7 Ryosuke Niwa 2011-06-22 16:27:42 PDT
(In reply to comment #6)
> Yes.  We should remove those from the list of core builders, IMHO.  The core page is too red now to be useful.

The rest of core builders are worse.  Windows and GTK are almost always red.  We'll have no tests core builders.  The problem is that people are landing patches that make the tree red, not that people aren't taking care of bots.
Comment 9 Adam Barth 2011-07-11 11:50:20 PDT
Ok.  Your persistence is commendable.
Comment 10 Ryosuke Niwa 2011-07-11 13:18:10 PDT
(In reply to comment #9)
> Ok.  Your persistence is commendable.

Thanks for r+.  I'll land it later when the tree is less busy.
Comment 11 Ryosuke Niwa 2011-07-11 19:17:39 PDT
Committed r90804: <http://trac.webkit.org/changeset/90804>