Bug 63195 - REGRESSION (r89460): media/media-controls-clone.html failing on Windows 7 Release (Tests)
Summary: REGRESSION (r89460): media/media-controls-clone.html failing on Windows 7 Rel...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows 7
: P2 Normal
Assignee: Kent Tamura
URL: http://build.webkit.org/results/Windo...
Keywords: LayoutTestFailure, MakingBotsRed, Regression
Depends on:
Blocks:
 
Reported: 2011-06-22 15:39 PDT by Adam Roben (:aroben)
Modified: 2011-06-24 04:34 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2011-06-22 15:39:30 PDT
media/media-controls-clone.html has been failing on Windows 7 Release (Tests) since r89462.

http://build.webkit.org/results/Windows%207%20Release%20(Tests)/r89457%20(14030)/results.html passed
http://build.webkit.org/results/Windows%207%20Release%20(Tests)/r89462%20(14031)/results.html failed
Comment 1 Dmitry Titov 2011-06-22 15:45:52 PDT
Likely a result of http://trac.webkit.org/changeset/89460
It was a revert of a series of patches that were changing this file in non-trivial ways (copying it from another etc). Likely should be restored with the right snapshot.
Comment 2 Kent Tamura 2011-06-22 19:14:08 PDT
Fixed by http://trac.webkit.org/changeset/89519
It is basically a new test.  So it's ok to land the current result.

On r89407, Windows had no expectation for media-contros-clone.html.
I mistakenly added it and corrected it in r89410 and r89411. r89460 removed it.
Comment 3 Adam Roben (:aroben) 2011-06-23 06:28:14 PDT
Is this line of test output really what we want?

CONSOLE MESSAGE: line 3: ReferenceError: Can't find variable: run

Thanks for checking in new results!
Comment 4 Kent Tamura 2011-06-24 04:34:15 PDT
(In reply to comment #3)
> CONSOLE MESSAGE: line 3: ReferenceError: Can't find variable: run

Oh, the test has unnecessary calls against non-existing function. I'll remove it and update expectations.