Bug 63140 - IndexedDB: fix multiple issues in IDBDatabase.idl
Summary: IndexedDB: fix multiple issues in IDBDatabase.idl
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 62414 62415 62416 63117 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-22 07:59 PDT by Mark Pilgrim (Google)
Modified: 2011-06-22 11:03 PDT (History)
5 users (show)

See Also:


Attachments
Patch (36.65 KB, patch)
2011-06-22 08:09 PDT, Mark Pilgrim (Google)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Pilgrim (Google) 2011-06-22 07:59:04 PDT
This is a consolidated patch that fixes the following issues, some of which were previously reported in separate and overlapping bugs:

- createObjectStore() should throw TypeError if required name argument is missing (bug 62414)
- createObjectStore() should treat null name argument as "null" (bug 63117)
- deleteObjectStore() should throw TypeError if required name argument is missing (bug 62415)
- deleteObjectStore() should treat null name argument as "null"
- setVersion() should throw TypeError if required version argument is missing (bug 62401)
- setVersion() should treat null version argument as "null" (bug 62401)
- transaction() should throw TypeError if required storeNames argument is missing (bug 62416)
- transaction() should treat null storeNames argument as "null"
Comment 1 Mark Pilgrim (Google) 2011-06-22 08:09:28 PDT
Created attachment 98174 [details]
Patch
Comment 2 Mark Pilgrim (Google) 2011-06-22 08:13:00 PDT
*** Bug 62414 has been marked as a duplicate of this bug. ***
Comment 3 Mark Pilgrim (Google) 2011-06-22 08:13:58 PDT
*** Bug 63117 has been marked as a duplicate of this bug. ***
Comment 4 Mark Pilgrim (Google) 2011-06-22 08:14:17 PDT
*** Bug 62415 has been marked as a duplicate of this bug. ***
Comment 5 Mark Pilgrim (Google) 2011-06-22 08:14:30 PDT
*** Bug 62416 has been marked as a duplicate of this bug. ***
Comment 6 Adam Barth 2011-06-22 10:25:43 PDT
Comment on attachment 98174 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=98174&action=review

> Source/WebCore/storage/IDBDatabase.idl:58
>          // EventTarget interface
>          void addEventListener(in DOMString type,
>                                in EventListener listener,
> -                              in boolean useCapture);
> +                              in [Optional] boolean useCapture);
>          void removeEventListener(in DOMString type,
>                                   in EventListener listener,
> -                                 in boolean useCapture);
> +                                 in [Optional] boolean useCapture);

There's some question about what the right thing here is globally, but I'm pretty sure this is what we're going to end up with.  The only question is whether we want to make that decision all-at-once or whether we want to convert these piecemeal.  I think it's ok to convert them piecemeal.
Comment 7 WebKit Review Bot 2011-06-22 11:03:47 PDT
Comment on attachment 98174 [details]
Patch

Clearing flags on attachment: 98174

Committed r89451: <http://trac.webkit.org/changeset/89451>
Comment 8 WebKit Review Bot 2011-06-22 11:03:53 PDT
All reviewed patches have been landed.  Closing bug.