Bug 62647 - Add PluginModuleInfo header and prepare for renaming of PluginInfoStore::Plugin to PluginModuleInfo
Summary: Add PluginModuleInfo header and prepare for renaming of PluginInfoStore::Plug...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-14 10:16 PDT by Anders Carlsson
Modified: 2011-06-14 10:37 PDT (History)
0 users

See Also:


Attachments
Patch (15.22 KB, patch)
2011-06-14 10:18 PDT, Anders Carlsson
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2011-06-14 10:16:54 PDT
Add PluginModuleInfo header and prepare for renaming of PluginInfoStore::Plugin to PluginModuleInfo
Comment 1 Anders Carlsson 2011-06-14 10:18:08 PDT
Created attachment 97134 [details]
Patch
Comment 2 Darin Adler 2011-06-14 10:20:52 PDT
Comment on attachment 97134 [details]
Patch

Given that almost all objects contain data or “info” I am not a big fan of “info” in class and function names.
Comment 3 Anders Carlsson 2011-06-14 10:25:04 PDT
(In reply to comment #2)
> (From update of attachment 97134 [details])
> Given that almost all objects contain data or “info” I am not a big fan of “info” in class and function names.

Right. I couldn't think of a better name, and since this class represents info about a plug-in module (as opposed to the plug-in module itself), I went with info.
Comment 4 Anders Carlsson 2011-06-14 10:37:30 PDT
Committed r88819: <http://trac.webkit.org/changeset/88819>