Bug 62543 - [GTK] [Stable] webkit-gtk-1.4.1: make argument list is too long
: [GTK] [Stable] webkit-gtk-1.4.1: make argument list is too long
Status: RESOLVED FIXED
: WebKit
New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-06-13 08:31 PST by
Modified: 2014-04-08 18:52 PST (History)


Attachments
environment (119.38 KB, text/plain)
2011-06-13 08:31 PST, Pacho Ramos
no flags Details
build.log (18.32 KB, text/plain)
2011-06-13 08:31 PST, Pacho Ramos
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-06-13 08:31:23 PST
Created an attachment (id=96958) [details]
environment

For a long time some users are hitting this problem downstream at:
http://bugs.gentoo.org/show_bug.cgi?id=300867

make -j3 XDG_DATA_HOME=/var/tmp/portage/net-libs/webkit-gtk-1.4.1-r200/temp/.local 
echo WTF_USE_NATIVE_GTK_MAIN_FRAME_SCROLLBAR=1 ENABLE_CHANNEL_MESSAGING=1 ENABLE_METER_TAG=1 ENABLE_PROGRESS_TAG=1 ENABLE_JAVASCRIPT_DEBUGGER=1 ENABLE_OFFLINE_WEB_APPLICATIONS=1 ENABLE_DATABASE=1 ENABLE_DATALIST=1 ENABLE_EVENTSOURCE=1 ENABLE_DOM_STORAGE=1 ENABLE_VIDEO=1 ENABLE_FULLSCREEN_API=1 ENABLE_XPATH=1 ENABLE_XSLT=1 ENABLE_WORKERS=1 ENABLE_SHARED_WORKERS=1 ENABLE_FILTERS=1 ENABLE_BLOB=1
make: execvp: echo: Argument list too long
make: *** [DerivedSources/webkit/WebKitDOMCSSRule.h] Error 127

Thanks for your help
------- Comment #1 From 2011-06-13 08:31:46 PST -------
Created an attachment (id=96959) [details]
build.log
------- Comment #2 From 2011-11-30 09:06:06 PST -------
You need a patched Make: http://thread.gmane.org/gmane.comp.gnu.make.bugs/4219
------- Comment #3 From 2011-12-18 03:37:01 PST -------
This is still failing even with patched make:
https://bugs.gentoo.org/show_bug.cgi?id=300867#c80
------- Comment #4 From 2012-01-04 01:21:35 PST -------
(In reply to comment #3)
> This is still failing even with patched make:
> https://bugs.gentoo.org/show_bug.cgi?id=300867#c80

The discussion in that downstream bug is a bit confusing, hard to follow. :(
Do you get some progress in the build after applying the suggestion of comment 15 of that bug?
------- Comment #5 From 2012-04-10 08:31:02 PST -------
*** Bug 83556 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2012-04-10 08:31:38 PST -------
*** Bug 76798 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2012-05-05 23:35:03 PST -------
(In reply to comment #0)
> Created an attachment (id=96958) [details] [details]
> environment
> 
> For a long time some users are hitting this problem downstream at:
> http://bugs.gentoo.org/show_bug.cgi?id=300867
> 
> make -j3 XDG_DATA_HOME=/var/tmp/portage/net-libs/webkit-gtk-1.4.1-r200/temp/.local 
> echo WTF_USE_NATIVE_GTK_MAIN_FRAME_SCROLLBAR=1 ENABLE_CHANNEL_MESSAGING=1 ENABLE_METER_TAG=1 ENABLE_PROGRESS_TAG=1 ENABLE_JAVASCRIPT_DEBUGGER=1 ENABLE_OFFLINE_WEB_APPLICATIONS=1 ENABLE_DATABASE=1 ENABLE_DATALIST=1 ENABLE_EVENTSOURCE=1 ENABLE_DOM_STORAGE=1 ENABLE_VIDEO=1 ENABLE_FULLSCREEN_API=1 ENABLE_XPATH=1 ENABLE_XSLT=1 ENABLE_WORKERS=1 ENABLE_SHARED_WORKERS=1 ENABLE_FILTERS=1 ENABLE_BLOB=1
> make: execvp: echo: Argument list too long
> make: *** [DerivedSources/webkit/WebKitDOMCSSRule.h] Error 127
> 
> Thanks for your help

This is problem from os. by default maximum argument size is hard coded in linux source. i have solved this issue by making changes in linux source limits.h.
ARG_MAX like macro. increase this value. make kernel and install it.
------- Comment #8 From 2012-05-06 01:57:24 PST -------
Is not possible to set ARG_MAX without needing to change the source?
------- Comment #9 From 2012-07-04 03:45:38 PST -------
(In reply to comment #8)
> Is not possible to set ARG_MAX without needing to change the source?

no, it is not possible to change
------- Comment #10 From 2012-08-10 06:26:58 PST -------
(In reply to comment #8)
> Is not possible to set ARG_MAX without needing to change the source?

Yes, with ulimit -s, you can see it being increased on getconf ARG_MAX.


The problem is that even after increasing this to ulimit -s unlimited, I still get:

make[1]: execvp: /bin/sh: Argument list too long
make[1]: *** [libWebCore.la] Error 127
make[1]: Leaving directory `/home/build/shell/src/webkit-1.9.6'

## Webkit version: 1.9.6
------- Comment #11 From 2014-04-08 18:52:53 PST -------
CMake fixes all these issues.