Biquad filter coefficient naming is incorrect
This is just a simple variable naming change to reflect the commonly used naming convention for biquad filters:
This is not a change in functionality, just in naming convention. The current names have the 'a' and 'b' variable names reversed. This patch changes the naming as follows:
m_a0 -> m_b0
m_a1 -> m_b1
m_b2 -> m_b2
m_b1 -> m_a1
m_b2 -> m_a2
This minor naming change will help clarify filter coefficient calculation from cookbook filter formulas.
Why did I have the names reversed in the first place? Because I was coding this from memory and got the names (if not the functionality) wrong.
Created attachment 95967 [details]
Comment on attachment 95967 [details]
Committed r88072: <http://trac.webkit.org/changeset/88072>