Bug 62011 - update the Xcode version on the /building/tools.html file site
Summary: update the Xcode version on the /building/tools.html file site
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Website (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: http://www.webkit.org/building/tools....
Depends on:
Reported: 2011-06-03 07:23 PDT by Patrick Mueller
Modified: 2016-02-03 11:32 PST (History)
5 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Mueller 2011-06-03 07:23:53 PDT
The web site's page http://www.webkit.org/building/tools.html currently lists XCode >= 3.1.4 as the version of XCode to use.  A thread on the mailing list from October 2011, titled "Any objections to switching to Xcode 3.2.4 or	newer?", at https://lists.webkit.org/pipermail/webkit-dev/2010-October/014972.html , seems to indicate >= 3.2.4 is required.

Since XCode 4.x flavors are also available, it would be good to state whether XCode 4 can be used, and if there's anything to watch out for if you do use it.
Comment 1 Alexey Proskuryakov 2011-06-03 08:44:55 PDT
Xcode 3.1.4 is the latest version for Mac OS X 10.5, so we can't require anything newer than that. Saying something specific about version for Snow Leopard might be useful, but I'd just suggest the newest.
Comment 2 Patrick Mueller 2011-06-03 09:46:12 PDT
There must be some kind of nuanced answer here, as the linked-to ml post from Darin reads, to me, as "you can use XCode >= 3.2.4".

I'd guess not many webkit devs outside of Apple are doing builds on 10.5, so perhaps the 10.5 requirement is actually something like "must not make dependencies on capabilities of XCode >= 3.1.4 for source in HEAD".

> I'd just suggest the newest

I'd like a specific statement about XCode 4.x.  I'm not sure if "newest" means "newest XCode" (XCode 4.x) or "newest 3.x XCode".
Comment 3 Alexey Proskuryakov 2011-06-03 10:24:25 PDT
Project files are compatible from at least Xcode 3.1 all the way to Xcode 4, so any version would build WebKit just fine.

The reason these discussions arise is that sometimes a certain version makes minor changes to project files (adding an inconsequential key, or re-ordering files differently). Sometimes this thrashing becomes a burden, and active contributors try to agree which specific version to use to avoid it.

Is there such a widespread problem now? What is the reason to spell out a specific version on the page?
Comment 4 Patrick Mueller 2011-06-03 11:05:49 PDT
Thanks for the clarification.  

I've worked with many, many toolkits/sdks over the years, and have learned to ask before moving up to new versions.  XCode is something I'm not very familiar with, yet.
Comment 5 Levi Weintraub 2011-06-27 12:17:39 PDT
It'd be nice to have some build instructions for XCode 4 anyhow -- as far as I can tell it doesn't "just work." I gave building WebCore a try with 4.0.2 and while building from the command line worked as expected, I couldn't get past forwarding header errors from the GUI.
Comment 6 Alexey Proskuryakov 2011-06-27 12:52:25 PDT
Sounds reasonable.

My guess if that the trouble you saw was caused to Xcode building projects to separate locations - you need to create and build a workspace with all projects, or change Xcode preferences to always build to a given directory. That said, I'm not sure if I have it all set up correctly either.
Comment 7 Levi Weintraub 2011-06-27 13:29:06 PDT
Know of any XCode ninjas who'd be willing to write up a quick Wiki? I know I'd certainly appreciate it :)
Comment 8 Levi Weintraub 2011-11-16 15:41:19 PST
Just restating that I know a lot of developers (myself among them!) who'd love to be able to use the most recent XCode IDE, but haven't succeeded in getting it to build WebKit. Any takers?
Comment 9 Jon Davis 2016-02-03 11:32:36 PST
The latest Xcode is referenced. Xcode 7 as of this comment.