Bug 62010 - Implement the DOMCrypt API
: Implement the DOMCrypt API
Status: RESOLVED INVALID
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript
: 528+ (Nightly build)
: All All
: P5 Enhancement
Assigned To: Jarred Nicholls
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-03 06:41 PDT by Jarred Nicholls
Modified: 2014-04-15 13:14 PDT (History)
15 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 David Dahl 2011-06-03 09:38:07 PDT
Currently, the spec is a bit rough and in flux, but I am working to update it as more feedback and criticism comes in. Also, I need to use WebIDL or something like that to make types crystal clear.
Comment 2 David Dahl 2011-06-03 09:39:07 PDT
A summary of the discussion is being built here: http://etherpad.mozilla.com:9000/DOMCrypt-discussion
Comment 3 Adam Barth 2011-06-03 13:28:13 PDT
I might as well own this bug for now.  Folk should feel free to steal it from me if they want.
Comment 4 David Dahl 2011-06-03 14:04:36 PDT
(In reply to comment #3)
> I might as well own this bug for now.  Folk should feel free to steal it from me if they want.

Don't hesitate to ping me on mozilla irc, as 'ddahl'.

I am working the WebIDL version of the spec right now and aggregating more feedback.
Comment 5 Jarred Nicholls 2011-06-06 05:30:20 PDT
I'll be doing some experimental implementation of this starting late next week; especially since the key exchange bits are going to be a sibling spec later on (wise move IMHO).  Assuming the WebIDL will be in the spec by then, I can verify it's not missing anything obvious (e.g. as of now the createHash method is missing its plain text argument, which I know isn't really the case but just an omission in the spec draft).
Comment 6 David Dahl 2011-06-06 07:30:24 PDT
 (In reply to comment #5)
> I'll be doing some experimental implementation of this starting late next week; especially since the key exchange bits are going to be a sibling spec later on (wise move IMHO).  Assuming the WebIDL will be in the spec by then, I can verify it's not missing anything obvious (e.g. as of now the createHash method is missing its plain text argument, which I know isn't really the case but just an omission in the spec draft).

I have started making a WebIDL document for the spec here: https://bug649154.bugzilla.mozilla.org/attachment.cgi?id=537428

This is the spec as the implementation stands right now - which is incorrect based on the feedback in the mailing lists. I am working on a new rev today that updates it for what we actually need.
Comment 7 Wade Colson 2014-04-15 13:02:39 PDT
*** Bug 260998 has been marked as a duplicate of this bug. ***
Seen from the domain http://volichat.com
Page where seen: http://volichat.com/random-chat-rooms
Marked for reference. Resolved as fixed @bugzilla.
Comment 8 Alexey Proskuryakov 2014-04-15 13:14:32 PDT
DOMCrypt evolved into WebCrypto, which we already implement.