Bug 61912 - [Refactoring] Node::nextRenderer() and previousRenderer() should be part of NodeRenderingContext
Summary: [Refactoring] Node::nextRenderer() and previousRenderer() should be part of N...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Hajime Morrita
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-02 00:29 PDT by Hajime Morrita
Modified: 2011-06-02 02:14 PDT (History)
1 user (show)

See Also:


Attachments
Patch (5.82 KB, patch)
2011-06-02 01:04 PDT, Hajime Morrita
tkent: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hajime Morrita 2011-06-02 00:29:43 PDT
This is a preparation for upcoming fix.
Comment 1 Hajime Morrita 2011-06-02 01:04:14 PDT
Created attachment 95735 [details]
Patch
Comment 2 Kent Tamura 2011-06-02 01:34:53 PDT
Comment on attachment 95735 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=95735&action=review

> Source/WebCore/dom/NodeRenderingContext.cpp:118
> +    for (Node* n = m_node->nextSibling(); n; n = n->nextSibling()) {

nit: one-letter variable name

> Source/WebCore/dom/NodeRenderingContext.cpp:143
> +    for (Node* n = m_node->previousSibling(); n; n = n->previousSibling()) {

ditto.
Comment 3 Hajime Morrita 2011-06-02 01:57:26 PDT
Hi Kent-san, thank you for reviewing!

(In reply to comment #2)
> (From update of attachment 95735 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=95735&action=review
> 
> > Source/WebCore/dom/NodeRenderingContext.cpp:118
> > +    for (Node* n = m_node->nextSibling(); n; n = n->nextSibling()) {
> 
> nit: one-letter variable name
Woa, will rename before landing...
Comment 4 Hajime Morrita 2011-06-02 02:14:43 PDT
Committed r87885: <http://trac.webkit.org/changeset/87885>