Bug 61804 - Change InlineBox::paint and its overloaded variants to use IntPoint
Summary: Change InlineBox::paint and its overloaded variants to use IntPoint
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Levi Weintraub
URL:
Keywords:
Depends on:
Blocks: 60318
  Show dependency treegraph
 
Reported: 2011-05-31 13:30 PDT by Levi Weintraub
Modified: 2011-05-31 19:30 PDT (History)
4 users (show)

See Also:


Attachments
Patch (23.45 KB, patch)
2011-05-31 14:37 PDT, Levi Weintraub
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Levi Weintraub 2011-05-31 13:30:57 PDT
InlineBox::paint has 7 overloaded versions.
Comment 1 Levi Weintraub 2011-05-31 14:22:53 PDT
Also changing RootInlineBox::paintEllipsisBox since it's basically just a shell around this same paint function.
Comment 2 Levi Weintraub 2011-05-31 14:37:26 PDT
Created attachment 95484 [details]
Patch
Comment 3 Levi Weintraub 2011-05-31 14:54:30 PDT
Thanks for the review!
Comment 4 Levi Weintraub 2011-05-31 14:55:45 PDT
Comment on attachment 95484 [details]
Patch

Clearing flags on attachment: 95484

Committed r87753: <http://trac.webkit.org/changeset/87753>
Comment 5 Levi Weintraub 2011-05-31 14:55:51 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Eric Seidel (no email) 2011-05-31 19:30:35 PDT
Comment on attachment 95484 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=95484&action=review

Looks OK besides that one line.

> Source/WebCore/rendering/EllipsisBox.cpp:71
> +        adjustedPaintOffset.move(m_x + m_logicalWidth - m_markupBox->x(),
> +            m_y + style->fontMetrics().ascent() - (m_markupBox->y() + m_markupBox->renderer()->style(m_firstLine)->fontMetrics().ascent()));

Wow, this is hard to read.