Bug 61524 - Web Audio API Inconsistencies
: Web Audio API Inconsistencies
Status: RESOLVED DUPLICATE of bug 70093
Product: WebKit
Classification: Unclassified
Component: Web Audio
: 528+ (Nightly build)
: PC Windows XP
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-26 07:11 PDT by mike
Modified: 2014-01-09 06:15 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike 2011-05-26 07:11:08 PDT
There are two inconsistencies in the current version of the Web Audio API specification (v1.0.32 at http://chromium.googlecode.com/svn/trunk/samples/audio/specification/specification.html ):

- 4.10. The AudioBufferSourceNode Interface
The "loop" attribute referenced in the documentation is named "looping"
- 4.13. The AudioProcessingEvent Interface
The event does not seem to contain the "playbackTime" attribute

These inconsistencies were discovered on a Windows XP machine running Chrome 13.0.767.1 dev-m.
Comment 1 Chris Rogers 2011-07-25 16:42:42 PDT
Addressed the .looping -> .loop change here:
http://trac.webkit.org/changeset/91723

Now, to fix .playbackTime...
Comment 2 Adam Goode 2012-07-23 18:24:31 PDT
Any update on this? I really miss playbackTime.
Comment 3 Chris Rogers 2013-05-10 17:45:48 PDT
For .playbackTime, marking this as duplicate of https://bugs.webkit.org/show_bug.cgi?id=70093

*** This bug has been marked as a duplicate of bug 70093 ***
Comment 4 Cristiano Belloni 2014-01-09 06:15:46 PST
Except #70093 is not exactly a duplicate of this.

This is realated to the playbackTime in the AudioProcessingEvent passed to an AudioBufferSourceNode calback, which is in the W3 specs while it is not in the implementation (currently, Chrome 31.0.1650.63 does not support the playbackTime attribute).

#70093 is about the introduction of another attribute (playbackPosition) in a AudioBufferSourceNode. They're completely different beasts, IMHO.