Bug 61384 - Let's just have one way to get the system page size, bokay?
Summary: Let's just have one way to get the system page size, bokay?
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Geoffrey Garen
URL:
Keywords:
: 58572 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-24 12:16 PDT by Geoffrey Garen
Modified: 2011-05-26 13:03 PDT (History)
3 users (show)

See Also:


Attachments
Patch (18.85 KB, patch)
2011-05-24 12:17 PDT, Geoffrey Garen
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2011-05-24 12:16:50 PDT
Let's just have one way to get the system page size, bokay?
Comment 1 Geoffrey Garen 2011-05-24 12:17:07 PDT
Created attachment 94661 [details]
Patch
Comment 2 WebKit Review Bot 2011-05-24 12:20:39 PDT
Attachment 94661 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/CMakeListsEfl.txt', ..." exit_code: 1

Source/JavaScriptCore/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/JavaScriptCore/heap/MarkStack.h:234:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Total errors found: 2 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Oliver Hunt 2011-05-24 12:27:18 PDT
Comment on attachment 94661 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=94661&action=review

> Source/JavaScriptCore/wtf/PageBlock.cpp:75
> +    return 256 * 1024;

wow....
Comment 4 Geoffrey Garen 2011-05-24 13:51:57 PDT
Committed r87198: <http://trac.webkit.org/changeset/87198>
Comment 5 Adam Roben (:aroben) 2011-05-26 13:03:35 PDT
*** Bug 58572 has been marked as a duplicate of this bug. ***