Bug 61245 - When removing a shadow root from DOM, also remove it from the render tree
Summary: When removing a shadow root from DOM, also remove it from the render tree
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dominic Cooney
URL:
Keywords:
Depends on:
Blocks: 59571
  Show dependency treegraph
 
Reported: 2011-05-22 02:32 PDT by Dominic Cooney
Modified: 2011-05-22 08:56 PDT (History)
2 users (show)

See Also:


Attachments
Patch (2.57 KB, patch)
2011-05-22 02:40 PDT, Dominic Cooney
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Cooney 2011-05-22 02:32:01 PDT
I have diagnosed the cause of the crashes discussed in bug 59571 as a shadow root remaining in the render tree after it is removed from the DOM. When a shadow root is removed from the DOM, it should also be removed from the render tree.
Comment 1 Dominic Cooney 2011-05-22 02:40:49 PDT
Created attachment 94338 [details]
Patch
Comment 2 Dimitri Glazkov (Google) 2011-05-22 07:51:04 PDT
Comment on attachment 94338 [details]
Patch

OMG. Good find.
Comment 3 WebKit Commit Bot 2011-05-22 08:56:16 PDT
Comment on attachment 94338 [details]
Patch

Clearing flags on attachment: 94338

Committed r87029: <http://trac.webkit.org/changeset/87029>
Comment 4 WebKit Commit Bot 2011-05-22 08:56:21 PDT
All reviewed patches have been landed.  Closing bug.