Bug 61133 - Web Inspector: breakpoints disappear from ui after navigation.
: Web Inspector: breakpoints disappear from ui after navigation.
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated)
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Pavel Podivilov
:
Depends on: 61195
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-19 11:02 PDT by Pavel Podivilov
Modified: 2011-05-20 09:26 PDT (History)
10 users (show)

See Also:


Attachments
Patch. (2.50 KB, patch)
2011-05-20 09:06 PDT, Pavel Podivilov
no flags Details | Formatted Diff | Diff
Patch. (2.50 KB, patch)
2011-05-20 09:07 PDT, Pavel Podivilov
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Podivilov 2011-05-19 11:02:41 PDT
Web Inspector: breakpoints disappear from ui after navigation.

After navigation, breakpoints are removed from _breakpointsWithoutSourceFile and asynchronously added to sourceFile.breakpoints. If another navigation happens in the middle, breakpoints are lost.
Comment 1 Pavel Podivilov 2011-05-20 09:06:22 PDT
Created attachment 94230 [details]
Patch.
Comment 2 Pavel Podivilov 2011-05-20 09:07:03 PDT
Created attachment 94231 [details]
Patch.
Comment 3 Pavel Podivilov 2011-05-20 09:09:54 PDT
*** Bug 61189 has been marked as a duplicate of this bug. ***
Comment 4 Pavel Podivilov 2011-05-20 09:13:02 PDT
Committed r86958: <http://trac.webkit.org/changeset/86958>
Comment 5 Pavel Podivilov 2011-05-20 09:26:02 PDT
Committed r86963: <http://trac.webkit.org/changeset/86963>