Bug 60900 - Web Inspector: refactoring: ScriptDebugListener::didParseSource has too many parameters.
Summary: Web Inspector: refactoring: ScriptDebugListener::didParseSource has too many ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Podivilov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-16 10:02 PDT by Pavel Podivilov
Modified: 2011-05-18 06:51 PDT (History)
11 users (show)

See Also:


Attachments
Patch. (11.21 KB, patch)
2011-05-16 10:03 PDT, Pavel Podivilov
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff
Fix style. (11.20 KB, patch)
2011-05-16 10:10 PDT, Pavel Podivilov
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff
Fix warning. (11.23 KB, patch)
2011-05-16 11:23 PDT, Pavel Podivilov
yurys: review-
Details | Formatted Diff | Diff
Patch. (11.13 KB, patch)
2011-05-17 10:21 PDT, Pavel Podivilov
yurys: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Podivilov 2011-05-16 10:02:36 PDT
Web Inspector: refactoring: ScriptDebugListener::didParseSource has too many parameters.
Comment 1 Pavel Podivilov 2011-05-16 10:03:14 PDT
Created attachment 93657 [details]
Patch.
Comment 2 WebKit Review Bot 2011-05-16 10:05:58 PDT
Attachment 93657 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1

Source/WebCore/inspector/ScriptDebugListener.h:68:  The parameter name "script" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:123:  The parameter name "script" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 2 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Pavel Podivilov 2011-05-16 10:10:22 PDT
Created attachment 93659 [details]
Fix style.
Comment 4 WebKit Review Bot 2011-05-16 10:12:50 PDT
Comment on attachment 93657 [details]
Patch.

Attachment 93657 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/8698919
Comment 5 WebKit Review Bot 2011-05-16 10:22:28 PDT
Comment on attachment 93659 [details]
Fix style.

Attachment 93659 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/8699909
Comment 6 Pavel Podivilov 2011-05-16 11:23:18 PDT
Created attachment 93676 [details]
Fix warning.
Comment 7 Yury Semikhatsky 2011-05-17 07:31:09 PDT
Comment on attachment 93676 [details]
Fix warning.

View in context: https://bugs.webkit.org/attachment.cgi?id=93676&action=review

> Source/WebCore/inspector/ScriptDebugListener.h:50
> +            , endColumn(0)

linesCount(0) is missing

> Source/WebCore/inspector/ScriptDebugListener.h:62
> +        int linesCount;

This field is never used, please remove it.
Comment 8 Pavel Podivilov 2011-05-17 10:21:31 PDT
Created attachment 93786 [details]
Patch.
Comment 9 Pavel Podivilov 2011-05-17 10:21:40 PDT
(In reply to comment #7)
> (From update of attachment 93676 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=93676&action=review
> 
> > Source/WebCore/inspector/ScriptDebugListener.h:50
> > +            , endColumn(0)
> 
> linesCount(0) is missing
> 
> > Source/WebCore/inspector/ScriptDebugListener.h:62
> > +        int linesCount;
> 
> This field is never used, please remove it.

Done.
Comment 10 Pavel Podivilov 2011-05-18 06:51:22 PDT
Committed r86756: <http://trac.webkit.org/changeset/86756>