Bug 60710 - JavaScriptGlue should compile with -Wmissing-prototypes
Summary: JavaScriptGlue should compile with -Wmissing-prototypes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: David Kilzer (:ddkilzer)
URL:
Keywords:
: 60704 60705 60706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-12 10:58 PDT by David Kilzer (:ddkilzer)
Modified: 2014-04-24 16:45 PDT (History)
3 users (show)

See Also:


Attachments
Patch (2.27 KB, patch)
2011-05-12 10:58 PDT, David Kilzer (:ddkilzer)
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2011-05-12 10:58:30 PDT
Created attachment 93305 [details]
Patch

Reviewed by NOBODY (OOPS!).

Enabling -Wmissing-prototypes fixes an Xcode 4 project warning.

This also fixes the following compiler warning:

JavaScriptGlue/JSUtils.cpp:407:15: error: no previous prototype for function 'getThreadGlobalData' [-Werror,-Wmissing-prototypes,3]
JSGlobalData* getThreadGlobalData()
^

* Configurations/Base.xcconfig: Set
GCC_WARN_ABOUT_MISSING_PROTOTYPES = YES.
* JSUtils.cpp:
(getThreadGlobalData): Made static.
---
 3 files changed, 21 insertions(+), 2 deletions(-)
Comment 1 WebKit Review Bot 2011-05-12 11:01:14 PDT
Attachment 93305 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptGlue/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptGlue/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Total errors found: 1 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 2 Geoffrey Garen 2011-05-12 11:21:30 PDT
Comment on attachment 93305 [details]
Patch

r=me
Comment 3 David Kilzer (:ddkilzer) 2011-05-12 12:05:59 PDT
*** Bug 60704 has been marked as a duplicate of this bug. ***
Comment 4 David Kilzer (:ddkilzer) 2011-05-12 12:06:02 PDT
*** Bug 60705 has been marked as a duplicate of this bug. ***
Comment 5 David Kilzer (:ddkilzer) 2011-05-12 12:06:06 PDT
*** Bug 60706 has been marked as a duplicate of this bug. ***
Comment 6 David Kilzer (:ddkilzer) 2011-05-12 16:36:47 PDT
Committed r86396: <http://trac.webkit.org/changeset/86396>
Comment 7 Darin Adler 2014-04-24 16:45:22 PDT
Moving all JavaScriptGlue bugs to JavaScriptCore. The JavaScriptGlue framework itself is long gone. And most of the more recent bugs put in this component were put there by people who thought this was for some other aspect of “JavaScript glue” and have nothing to do with the actual original reason for the existence of this component, which was an OS-X-only framework named JavaScriptGlue.