RESOLVED FIXED 60663
Change nodeAtPoint to take IntPoint instead of int x, int y
https://bugs.webkit.org/show_bug.cgi?id=60663
Summary Change nodeAtPoint to take IntPoint instead of int x, int y
Emil A Eklund
Reported 2011-05-11 14:42:22 PDT
Change nodeAtPoint hit testing code to take an IntPoint argument instead of a pair of ints for x, y.
Attachments
Patch (62.21 KB, patch)
2011-05-16 16:28 PDT, Emil A Eklund
no flags
Patch (62.93 KB, patch)
2011-05-16 17:16 PDT, Emil A Eklund
no flags
Patch for landing (62.93 KB, patch)
2011-05-17 10:25 PDT, Emil A Eklund
no flags
Levi Weintraub
Comment 1 2011-05-11 15:41:56 PDT
Woo!
Emil A Eklund
Comment 2 2011-05-16 16:28:22 PDT
Emil A Eklund
Comment 3 2011-05-16 16:28:41 PDT
I tried to keep this as small as I could, more clean up and changing functions called by nodeAtPoint will follow in separate patches. I realize that the name pointInContainer might not be entirely correct but it was the best I could come up with. If you can think of a better name please do tell.
Simon Fraser (smfr)
Comment 4 2011-05-16 16:42:25 PDT
Comment on attachment 93710 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=93710&action=review > Source/WebCore/rendering/RenderBlock.cpp:3902 > + tx += x(); > + ty += y(); I don't like it when methods change parameter values. Maybe a local IntSize localOffset(tx + x(), ty + y())?
Eric Seidel (no email)
Comment 5 2011-05-16 17:01:10 PDT
Comment on attachment 93710 [details] Patch LGTM. Please respond to smfr before landing of course.
Emil A Eklund
Comment 6 2011-05-16 17:16:11 PDT
Emil A Eklund
Comment 7 2011-05-16 17:17:25 PDT
> I don't like it when methods change parameter values. Maybe a local IntSize localOffset(tx + x(), ty + y())? That's a good idea. Made the change you suggested. Please take another look.
Eric Seidel (no email)
Comment 8 2011-05-16 17:52:47 PDT
Comment on attachment 93715 [details] Patch still LGTM.
Emil A Eklund
Comment 9 2011-05-17 10:25:29 PDT
Created attachment 93788 [details] Patch for landing
WebKit Commit Bot
Comment 10 2011-05-17 11:29:30 PDT
Comment on attachment 93788 [details] Patch for landing Rejecting attachment 93788 [details] from commit-queue. Failed to run "['./Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=cr-jail-8', 'apply-..." exit_code: 1 Last 500 characters of output: autoinstalled/mechanize/_urllib2_fork.py", line 332, in _call_chain result = func(*args) File "/mnt/git/webkit-commit-queue/Tools/Scripts/webkitpy/thirdparty/autoinstalled/mechanize/_urllib2_fork.py", line 1170, in https_open return self.do_open(conn_factory, req) File "/mnt/git/webkit-commit-queue/Tools/Scripts/webkitpy/thirdparty/autoinstalled/mechanize/_urllib2_fork.py", line 1118, in do_open raise URLError(err) urllib2.URLError: <urlopen error [Errno 60] Operation timed out> Full output: http://queues.webkit.org/results/8709232
WebKit Commit Bot
Comment 11 2011-05-17 13:57:42 PDT
Comment on attachment 93788 [details] Patch for landing Clearing flags on attachment: 93788 Committed r86705: <http://trac.webkit.org/changeset/86705>
WebKit Commit Bot
Comment 12 2011-05-17 13:57:48 PDT
All reviewed patches have been landed. Closing bug.
WebKit Commit Bot
Comment 13 2011-05-17 14:58:49 PDT
The commit-queue encountered the following flaky tests while processing attachment 93788 [details]: http/tests/websocket/tests/multiple-connections.html bug 53825 (author: abarth@webkit.org) The commit-queue is continuing to process your patch.
Note You need to log in before you can comment on or make changes to this bug.