Both PlatformMouseEvent(QInputEvent*, int clickCount) and PlatformMouseEvent(QGraphicsSceneMouseEvent*, int clickCount) contain identical code to set the state of the keyboard modifiers for a mouse event. Instead, we should extract this code into a common function, say mouseEventModifiersFromQtKeyboardModifiers() so as to remove duplicate code.
Created attachment 93163 [details]
Comment on attachment 93163 [details]
Clearing flags on attachment: 93163
Committed r86273: <http://trac.webkit.org/changeset/86273>
All reviewed patches have been landed. Closing bug.