Bug 60499 - [Qt] DumpRenderTreeQt needs an implementation of unmarkText
Summary: [Qt] DumpRenderTreeQt needs an implementation of unmarkText
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Chang Shu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-09 12:54 PDT by Chang Shu
Modified: 2011-05-10 01:39 PDT (History)
2 users (show)

See Also:


Attachments
fix patch (5.54 KB, patch)
2011-05-09 13:19 PDT, Chang Shu
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chang Shu 2011-05-09 12:54:37 PDT
Should help to fix
editing/inserting/insert-composition-whitespace.html
Comment 1 Chang Shu 2011-05-09 13:19:46 PDT
Created attachment 92837 [details]
fix patch
Comment 2 Kenneth Rohde Christiansen 2011-05-09 15:21:21 PDT
Comment on attachment 92837 [details]
fix patch

Looks good. Are you going to use that confirmComposition for other tests? Because it is doing a lot more than unmarking text :-)
Comment 3 Chang Shu 2011-05-09 18:26:41 PDT
Maybe, I haven't realized it yet. :)
Thanks for the review.
(In reply to comment #2)
> (From update of attachment 92837 [details])
> Looks good. Are you going to use that confirmComposition for other tests? Because it is doing a lot more than unmarking text :-)
Comment 4 WebKit Commit Bot 2011-05-09 19:11:33 PDT
Comment on attachment 92837 [details]
fix patch

Clearing flags on attachment: 92837

Committed r86124: <http://trac.webkit.org/changeset/86124>
Comment 5 WebKit Commit Bot 2011-05-09 19:11:38 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Csaba Osztrogonác 2011-05-10 01:39:38 PDT
Guys, you should have to run layout tests before commiting and/or watch the buildbots after commiting. 

Please respect the rules: http://www.webkit.org/coding/contributing.html
"Once you have made your changes, you need to run the regression tests, which is done via the run-webkit-tests script. All tests must pass. Patches will not be landed in the tree if they break existing layout tests."

I landed a fix: http://trac.webkit.org/changeset/86137 instead of you ... :S