Bug 60429 - Crash when sending a wheel event to a node with no shadow ancestor node
Summary: Crash when sending a wheel event to a node with no shadow ancestor node
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Event Handling (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Jon Lee
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-05-06 19:54 PDT by Jon Lee
Modified: 2011-05-26 15:40 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.90 KB, patch)
2011-05-06 20:01 PDT, Jon Lee
alice.barraclough: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Lee 2011-05-06 19:54:39 PDT
Scrolling around this url causes the crash: http://upload.wikimedia.org/wikipedia/commons/7/74/Timeline_of_web_browsers.svg
Comment 1 Jon Lee 2011-05-06 19:57:57 PDT
<rdar://problem/9389619>
Comment 2 Jon Lee 2011-05-06 20:01:36 PDT
Created attachment 92683 [details]
Patch
Comment 3 mitz 2011-05-06 20:34:29 PDT
Is it not possible to add a regression test for this?
Comment 4 Jon Lee 2011-05-07 00:17:05 PDT
http://trac.webkit.org/changeset/86002
Comment 5 Jon Lee 2011-05-07 00:22:37 PDT
i thought it would not be possible because it would involve user input. I think the best kind of test would involve a reduction .svg, and then move the mouse over a text element in the .svg, and scroll. if that is possible then i can write a test for this.
Comment 6 mitz 2011-05-07 00:27:25 PDT
You can use the eventSender object to simulate moving the mouse and using the scroll wheel, something like

if (window.eventSender) {
    eventSender.mouseMoveTo(100, 100);
    eventSender.mouseScrollBy(0, 10);
}
Comment 7 Ademar Reis 2011-05-26 15:40:49 PDT
Revision r86002 cherry-picked into qtwebkit-2.2 with commit 6b2f436 <http://gitorious.org/webkit/qtwebkit/commit/6b2f436>