Bug 60336 - Selection target is incorrectly calculated when a line-height is applied
Summary: Selection target is incorrectly calculated when a line-height is applied
Status: RESOLVED DUPLICATE of bug 54929
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2011-05-05 21:25 PDT by Patrick Quinn-Graham
Modified: 2011-05-06 08:54 PDT (History)
4 users (show)

See Also:


Attachments
Simple reduction (294 bytes, text/html)
2011-05-05 21:25 PDT, Patrick Quinn-Graham
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Quinn-Graham 2011-05-05 21:25:11 PDT
Created attachment 92536 [details]
Simple reduction

When given a contenteditable with a line-height specified (even at 1.0em), clicking on the same line as your text, but after the text, places the text caret at the start of the line instead of the end of the line as expected.
Comment 1 Alexey Proskuryakov 2011-05-06 01:03:43 PDT
This is a regression from Safari 5.
Comment 2 Levi Weintraub 2011-05-06 08:49:11 PDT
FWIW, this is probably related to the issue behind Bug 54929.
Comment 3 Ryosuke Niwa 2011-05-06 08:54:29 PDT
Indeed, this is just a dup. of the bug 54929.

*** This bug has been marked as a duplicate of bug 54929 ***