Bug 60289 - visibility:hidden doesn't hide plugins on Mac
Summary: visibility:hidden doesn't hide plugins on Mac
Status: RESOLVED DUPLICATE of bug 44368
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P2 Normal
Assignee: Nobody
URL: data:text/html,<embed style="visibili...
Keywords: InRadar, PlatformOnly
Depends on:
Blocks:
 
Reported: 2011-05-05 12:20 PDT by Adam Roben (:aroben)
Modified: 2011-05-06 07:24 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2011-05-05 12:20:41 PDT
(This was split out from bug 60285.)

To reproduce:

1. Go to data:text/html,<embed style="visibility:hidden" src="http://www.flashexample.com/system/files/sites/flashexample.com/files/upload/clock.swf" type="application/x-shockwave-flash" width=300 height=300>

The plugin is visible, but should be hidden. This occurs in both WebKit1 and WebKit2.
Comment 1 Adam Roben (:aroben) 2011-05-05 12:23:04 PDT
This bug does not occur in Firefox 4.
Comment 2 Adam Roben (:aroben) 2011-05-05 12:23:53 PDT
<rdar://problem/9391219>
Comment 3 Alexey Proskuryakov 2011-05-05 22:31:05 PDT
Duplicate of bug 44368?
Comment 4 Adam Roben (:aroben) 2011-05-06 07:24:41 PDT
Yep!

*** This bug has been marked as a duplicate of bug 44368 ***