Bug 60048 - store results.html options in localstorage
Summary: store results.html options in localstorage
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Ojan Vafai
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-03 11:49 PDT by Ojan Vafai
Modified: 2011-05-03 13:51 PDT (History)
3 users (show)

See Also:


Attachments
Patch (6.13 KB, patch)
2011-05-03 11:51 PDT, Ojan Vafai
tony: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ojan Vafai 2011-05-03 11:49:56 PDT
store results.html options in localstorage
Comment 1 Ojan Vafai 2011-05-03 11:51:33 PDT
Created attachment 92098 [details]
Patch
Comment 2 Eric Seidel (no email) 2011-05-03 12:03:17 PDT
Comment on attachment 92098 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=92098&action=review

> LayoutTests/fast/harness/resources/results-test.js:65
> +function runTest(results, assertions, opt_localStorageValue)

opt_?  Funny prefix.
Comment 3 Ojan Vafai 2011-05-03 12:15:09 PDT
(In reply to comment #2)
> (From update of attachment 92098 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=92098&action=review
> 
> > LayoutTests/fast/harness/resources/results-test.js:65
> > +function runTest(results, assertions, opt_localStorageValue)
> 
> opt_?  Funny prefix.

It's a convention I picked up from Google's JS code. I'm happy to remove the prefix or do something different. It's useful to be able to specify that an argument is optional though.
Comment 4 Tony Chang 2011-05-03 13:37:32 PDT
Comment on attachment 92098 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=92098&action=review

>>> LayoutTests/fast/harness/resources/results-test.js:65

>> 
>> opt_?  Funny prefix.
> 
> It's a convention I picked up from Google's JS code. I'm happy to remove the prefix or do something different. It's useful to be able to specify that an argument is optional though.

The opt_ prefix seems fine considering we already checked in some code for it.  We can discuss/change if we decide to have a JS style guide.
Comment 5 Ojan Vafai 2011-05-03 13:51:59 PDT
Committed r85654: <http://trac.webkit.org/changeset/85654>