Bug 60043 - Safari.dll-related crash when navigating to any page (e.g. google.com)
Summary: Safari.dll-related crash when navigating to any page (e.g. google.com)
Status: RESOLVED DUPLICATE of bug 60081
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows 7
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-05-03 11:24 PDT by Alexander Pavlov (apavlov)
Modified: 2011-05-03 16:54 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pavlov (apavlov) 2011-05-03 11:24:09 PDT
Clean debug build with MSVS 2005.

 	oleaut32.dll!_SysStringLen@4()  + 0xc bytes	
>	WebKit.dll!WebView::registerEmbeddedViewMIMEType(wchar_t * mimeType=0x00000001)  Line 6031 + 0xc bytes	C++
 	Safari.dll!BrowserView::committedFrame()  + 0x180 bytes	
 	Safari.dll!BrowserDelegate::didCommitLoadForFrame()  + 0x33 bytes	
 	WebKit.dll!WebFrameLoaderClient::dispatchDidCommitLoad()  Line 395 + 0x26 bytes	C++
 	WebKit.dll!WebCore::FrameLoader::dispatchDidCommitLoad()  Line 3449 + 0x18 bytes	C++
 	WebKit.dll!WebCore::FrameLoader::receivedFirstData()  Line 609	C++
 	WebKit.dll!WebCore::FrameLoader::willSetEncoding()  Line 1135	C++
 	WebKit.dll!WebCore::DocumentWriter::setEncoding(const WTF::String & name={...}, bool userChosen=false)  Line 240	C++
 	WebKit.dll!WebCore::DocumentLoader::commitData(const char * bytes=0x076b8e00, int length=14253)  Line 320	C++
 	WebKit.dll!WebFrameLoaderClient::committedLoad(WebCore::DocumentLoader * loader=0x074c7710, const char * data=0x076b8e00, int length=14253)  Line 500	C++
 	WebKit.dll!WebCore::DocumentLoader::commitLoad(const char * data=0x076b8e00, int length=14253)  Line 307 + 0x29 bytes	C++
 	WebKit.dll!WebCore::DocumentLoader::receivedData(const char * data=0x076b8e00, int length=14253)  Line 334	C++
 	WebKit.dll!WebCore::MainResourceLoader::addData(const char * data=0x076b8e00, int length=14253, bool allAtOnce=false)  Line 169	C++
 	WebKit.dll!WebCore::ResourceLoader::didReceiveData(const char * data=0x076b8e00, int length=14253, __int64 encodedDataLength=14253, bool allAtOnce=false)  Line 279 + 0x1b bytes	C++
 	WebKit.dll!WebCore::MainResourceLoader::didReceiveData(const char * data=0x076b8e00, int length=14253, __int64 encodedDataLength=14253, bool allAtOnce=false)  Line 464	C++
 	WebKit.dll!WebCore::ResourceLoader::didReceiveData(WebCore::ResourceHandle * __formal=0x0753b828, const char * data=0x076b8e00, int length=14253, int encodedDataLength=14253)  Line 430 + 0x1f bytes	C++
 	WebKit.dll!WebCore::didReceiveData(_CFURLConnection * conn=0x0716bb08, const __CFData * data=0x076a9698, long originalLength=14253, const void * clientInfo=0x0753b828)  Line 211 + 0x2a bytes	C++
 	CFNetwork.dll!URLConnectionClient::_clientDidReceiveData()  + 0xa9 bytes	
 	CFNetwork.dll!URLConnectionClient::ClientConnectionEventQueue::processAllEventsAndConsumePayload()  + 0x211 bytes	
 	CFNetwork.dll!XConnectionEventQueue<enum XClientEvent,XClientEventParams>::processAllEvents()  + 0x14 bytes	
 	CFNetwork.dll!URLConnectionClient::ClientConnectionEventQueue::processAllEventsAndConsumePayload()  + 0x32c bytes	
 	CFNetwork.dll!XConnectionEventQueue<enum XClientEvent,XClientEventParams>::processAllEvents()  + 0x14 bytes	
 	CFNetwork.dll!URLConnectionClient::processEvents()  + 0x44 bytes	
 	CFNetwork.dll!MirroredSet::contains()  + 0x5b bytes	
 	user32.dll!_InternalCallWinProc@20()  + 0x23 bytes	
 	user32.dll!_UserCallWinProcCheckWow@32()  + 0xb7 bytes	
 	user32.dll!_DispatchMessageWorker@8()  + 0xed bytes	
 	user32.dll!_DispatchMessageW@4()  + 0xf bytes	
 	Safari.dll!ATL::CWindow::ClientToScreen()  + 0x269 bytes	
 	Safari.dll!run()  + 0xfb bytes	
 	Safari.dll!safariMain()  + 0x596 bytes	
 	Safari.dll!_safariDLLMain@16()  + 0x38 bytes	
 	Safari.exe!_wWinMain@16()  + 0x217 bytes	
 	Safari.exe!@__security_check_cookie@4()  + 0x1aa bytes	
 	kernel32.dll!@BaseThreadInitThunk@12()  + 0x12 bytes	
 	ntdll.dll!___RtlUserThreadStart@8()  + 0x27 bytes	
 	ntdll.dll!__RtlUserThreadStart@8()  + 0x1b bytes
Comment 1 Jessie Berlin 2011-05-03 11:25:54 PDT
<rdar://problem/9375922>
Comment 2 Brian Weinstein 2011-05-03 16:54:15 PDT

*** This bug has been marked as a duplicate of bug 60081 ***