Bug 59973 - In Aperture, a WebView might be dealloc'ed before it finishes loading
Summary: In Aperture, a WebView might be dealloc'ed before it finishes loading
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P2 Normal
Assignee: Brady Eidson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-05-02 16:19 PDT by Brady Eidson
Modified: 2011-06-18 11:57 PDT (History)
1 user (show)

See Also:


Attachments
Patch v1 (5.47 KB, patch)
2011-05-02 16:38 PDT, Brady Eidson
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2011-05-02 16:19:44 PDT
In Aperture, a WebView might be dealloc'ed before didFinishLoading: is called.

The problem is that the client isn't properly retaining an offscreen WebView when they should be.  Therefore the WebView is dealloc'ed when the last subresource finishes loading, and the client is never told that the load completes (because it doesn't!)

Aperture specific quirk patch is on its way.

In radar as <rdar://problem/9340945>
Comment 1 Brady Eidson 2011-05-02 16:38:46 PDT
Created attachment 92003 [details]
Patch v1
Comment 2 Darin Adler 2011-06-18 11:57:00 PDT
r85549